2
$\begingroup$

Using Cycles,I have a scene with Volume Scatter shader connected to World Background and an HDR image connected to the surface, Rendering the scene while checking Environment pass is giving me a nice full black image "naturally" even with Transparency enabled in the the Render > Film, so far it's understood, so I'm planning to separate the procedure, making a render for the combined pass, then another for the Environment pass with the Background shaders disconnected in order to get the Alpha. The problem is Cycles re-renders the Combined pass in the second step, even by having it disabled in the Render Layers > Passes. How come? Why is Combined pass rendering while being unchecked? In case I'm not doing anything wrong, yet this is the way it is, is there a turn around?

$\endgroup$
3
$\begingroup$

You can't use both volume scatter and a background in the world settings at the same time (read this post).

The workaround is creating a "domain" object around the area where you need the volume scattering. In order to be transparent, the domain will have no surface and only volume scattering.

Your HDRi world texture can then be used normally (Keep in mind that volume scatter will make things a bit darker so you might need to make your light sources and environment texture brighter).

enter image description here (HDRi by Giant Cow Films)

$\endgroup$
  • $\begingroup$ I have a similar problem but I feel that the solution proposed here does not apply to my problem. Could you please take a look at my question here and see if you know how I can only render depth or surface Normals, but not RGB? $\endgroup$ – Amir Mar 8 '18 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.