3
$\begingroup$

This question already has an answer here:

Maybe you can help me with a weird viewport issue.

I want to show only visible edges in edit mode. i.e. I don't want to see those on the back side of the model. For some reason I always see partial edges in Solid Mode.

See the first image. There appears to be an 'inner cube' within my model. It occludes backface edges partially.

Cube

When I search on this topic people suggest toggling 'Limit Selection to Visible' in edit mode, and when I turn it on I can see all backface edges as expected, but the inner cube is still there.

It shows up in other models as well, like these steps: Steps

Any suggestions?

$\endgroup$

marked as duplicate by cegaton, Mr Zak, VRM, PGmath, X-27 Mar 26 '16 at 3:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1
$\begingroup$

I don't really know the correct answer to this one, I think this is a limitation of the current opengl viewport rendering engine. Would like to hear from one of the devs about it, if it is actually fixable or a bug, or if anyone else knows any other way to fix it.

Only way to remedy the situation I found is to adjust viewport clipping. It's a workaround with its own side effects but can minimize the issue.

In the 3d view properties shelf N key, under the View panel there is a setting for viewpor clipping, star and end. Try bringing the two values closer together like increasing clip start and/or increasing clip end but keeping them in a usable state for your scene.

Edit: Worked well on my end enter image description here

Ok, missed one detail, if you are in camera view mode, then you need to adjust the clipping settings in the camera's Object Data Settings in the Properties window, not viewport clipping as it has no effect while in camera view mode.

$\endgroup$
  • $\begingroup$ Thanks for the info. Changing the clipping seems to have no effect. s25.postimg.org/kui76ymct/Clipping.png $\endgroup$ – Triad Mar 25 '16 at 15:19
  • $\begingroup$ Worked well on my viewport, may be something related to your graphics card or drivers, check the original answer $\endgroup$ – Duarte Farrajota Ramos Mar 25 '16 at 17:21
  • $\begingroup$ hmm strange. Are you viewing through Camera or Perspective? I can reproduce this in perspective, but camera remains the same: s25.postimg.org/9jfjilfhr/Cube_Camera_v_Perspective_final.png $\endgroup$ – Triad Mar 25 '16 at 18:14
  • $\begingroup$ Of right didn't remember that, if you are in camera view mode you need to adjust the clipping settings in the camera's Object Data Settings in the Properties window, viewport clipping has no effect while in camera view mode. $\endgroup$ – Duarte Farrajota Ramos Mar 25 '16 at 18:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.