2
$\begingroup$

So I'm trying to weight paint but can't seem to get my teeth and beard on the character to move with his head on two different bones, I have tried to move the head then weight paint it so that it gets moved into position as I paint but that doesn't work because it just stops getting closer to the head... so if someone could help using like team viewer or something that would help me a ton.

enter image description here newest image:

Failing

$\endgroup$
  • $\begingroup$ Try to assign a jaw/teeth vertices with a weight value=1.000 to the head bone. It should follow the head then. $\endgroup$ – Paul Gonet Mar 24 '16 at 0:09
  • $\begingroup$ sorry im new haha so if i go into edit mode and highlight what i want to change the value too, then where would i go to find the vertex weights tab? $\endgroup$ – Jaydon Mar 24 '16 at 0:30
  • $\begingroup$ Related: blender.stackexchange.com/questions/8227/… $\endgroup$ – Paul Gonet Mar 28 '16 at 22:59
3
$\begingroup$

I'll try to recreate the similiar issue as yours for you. As you can see below the jaw mesh doesn't follow the head's movement. It's because the jaw's vertices are not properly assigned to the head bone. enter image description here

Select the head bone in Pose Mode, then select the mesh. In Edit Mode select all the vertices that belongs to jaw. Go to the Mesh Data header and in the Vertex Groups panel assign (press the Assign button) them with the weight of 1.000 to the head bone. enter image description here


EDIT: I've weight painted the left side of your model. Unfortunatelly it wasn't symmetrical, so I couldn't mirror the weights to the right side of the rig. You'll have to do it manually. Here's the .blend:

| improve this answer | |
$\endgroup$
  • $\begingroup$ ok so that sort of works now whenever i move the head it moves the beard and mouth with it but it lags behind it, like for example i move the head and they follow its just a little bit behind and it clips through the head, and on the other joint that i move it does not move with it can i assign it too multiple joints? $\endgroup$ – Jaydon Mar 24 '16 at 3:51
  • $\begingroup$ It looks like some head vertices are assigned to other bones, like neck bone etc. You have to remove them from that bone (e.g. select the neck bone in Pose Mode, then select all the head vertices in Edit Mode and press Remove button in Vertex Grops panel). TIP: When parenting the mesh to the armature (Ctrl+P) use a With Automatic Weights option. It will assign automatically proper vertex groups to the proper bones. Then correct some weights using Assign and Remove buttons. $\endgroup$ – Paul Gonet Mar 25 '16 at 15:07
  • $\begingroup$ i already did that it didnt solve anything here is a new photos of my weight failing: ok it looks like that in the second photo $\endgroup$ – Jaydon Mar 25 '16 at 20:46
  • $\begingroup$ is there a way that i can hide everything i select in edit mode so that i can see only a select few items that i want then switch to weight mode on a joint??? Maby $\endgroup$ – Jaydon Mar 25 '16 at 20:50
  • $\begingroup$ or a way to group everything i want in edit mode so that when i am in weight mode i can weight everything i grouped really easy $\endgroup$ – Jaydon Mar 25 '16 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.