3
$\begingroup$

Still a bit of a noob with Blender and definitely with this stack exchange, so please go gentle!

Anyone else having a problem getting images (.png, .tiff, .jpg) to show up in an empty in the 2.77 release? I realize I can use a background image, but would rather use an empty for the perspective view. Tried disabling the "import images as planes" add-on, thinking that script might've altered something, but no luck.

Hope this issue isn't something moronically obvious that I'm missing here; many thanks ahead!

$\endgroup$
3
  • $\begingroup$ How do I get a constant Background Image? $\endgroup$
    – David
    Mar 24, 2016 at 18:27
  • $\begingroup$ (tab) into Object mode --> Properties tab (n) --> select Background images. Load it in. Note that you will only be able to see it in Orthographic view (5) on your numpad. $\endgroup$
    – j_a_l
    Mar 30, 2016 at 17:13
  • $\begingroup$ I had the same problem. But after I hit show overlays it comes back. Hope this can help. $\endgroup$
    – UncleB
    Oct 22, 2021 at 22:46

4 Answers 4

2
$\begingroup$

Use shiftA and select Add->Empty->Image

enter image description here

Then in the data section of the Properties panel Look for the Display control to open the image:

enter image description here

enter image description here

$\endgroup$
7
  • $\begingroup$ Thanks for the response. Loading it in isn't the problem. Maybe I should've been more specific about this. It shows it's loaded, but no matter which transparency or scaling parameters I choose, the image doesn't show up in the Empty itself, in 3D view. I wonder if this is a bug? $\endgroup$
    – j_a_l
    Mar 24, 2016 at 13:55
  • $\begingroup$ check the drivers for your graphics card. Which GPU are you using? $\endgroup$
    – user1853
    Mar 24, 2016 at 14:09
  • $\begingroup$ OpenCL. Tried switching to CPU just in case, but still no go. $\endgroup$
    – j_a_l
    Mar 24, 2016 at 17:04
  • $\begingroup$ It does look like a bug. If you are going to report it make sure you do include all relevant information (OS, Type of GPU, etc) blender.stackexchange.com/questions/1377/… $\endgroup$
    – user1853
    Mar 24, 2016 at 17:08
  • $\begingroup$ Thanks for the heads up. Yeah, it's strange: I can load in and use a background reference image in 3D view no problem; only in an Empty does this issue occur. $\endgroup$
    – j_a_l
    Mar 24, 2016 at 17:10
1
$\begingroup$

There is a workaround. Blendercoders assisted with this one: 'Set UserPref -> System -> Clip Alpha to.. 0.005' and/or load factory settings. This worked for me.

$\endgroup$
4
  • 1
    $\begingroup$ I have the same problem and tried the above and no luck. Any other ideas? I'm assuming this is a bug. I've been trying to learn blender but these show stoppers just leave you scratching your head. I put in a new empty plane and an image for my sculpt. The image doesn't show up and I'm stumped since I'm very new as to what is causing this. $\endgroup$ Jul 14, 2016 at 2:11
  • $\begingroup$ @imaginethepoet, have you tried loading factory settings in the File pop-down menu? I double-checked and the previous workaround Clip Alpha 0.005 still works on my end. You sure you're adding an Empty and not trying to add a Background Image? If you're choosing the latter, make sure you're in Ortho view to see it; won't show up by default in Perspective view. $\endgroup$
    – j_a_l
    Jul 15, 2016 at 19:26
  • $\begingroup$ Hi, yes I tried this on my mac and I'm having the same problem. I changed the clip on alpha and closed out the file and tried again. I'm in Ortho mode after I changed the mac to allow for emulating keys. Still no image is showing up. Any other ideas or maybe I should revert to an older version? $\endgroup$ Jul 17, 2016 at 1:07
  • $\begingroup$ You can always revert back to the earlier version, but there should be a way to fix this. Attach some screenshots and a detailed account of your workflow. $\endgroup$
    – j_a_l
    Jul 20, 2016 at 15:36
0
$\begingroup$

I think I found the solution - make sure you're in the "Modeling" tab as opposed to the "Layout" tab. Not sure why, but the Empties are in fact empty in Layout view.

Found that after trying all of the above and seeing no difference, but it might need the combination.

-Destructor

$\endgroup$
0
$\begingroup$

Just experienced the same problem and found out that "Empty Images" are categorized as "Extras" in the Overlay Options. I had Extras turned off, so the image wasn't showing.

So for anyone with this problem, check under Viewport Overlays and enable Extras and your "Empty Image" should be visible again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.