3
$\begingroup$

This is the problem I'm stumbling upon a lot recently. You start sculpting on perfectly flat surface, then you make some creases, maybe deeper creases, or maybe you are building geometry with inflate brush inside a hole like eye socket, but eventually this happens - you have a crease in your geometry that is so deep that no amount of smoothing or scraping is going to get rid of.

Actually when you look at it in edit mode it looks like a bubble of geometry that is stuck under the "skin" of your model. The only way to repair this place is to switch to edit mode and then just remove offending geometry vertex by vertex, then close the hole with some polygons or even one big n-gon and then you can sculpt in this area again.

My question is - is it possible to flatten or smooth (repair) such area quickly, with sculpting tools, without going out of sculpt mode?

Please take a look at these images:

sculpt

sculpt

The view from inside of the head, offending geometry looks like an air bubble:

sculpt inside

$\endgroup$
  • $\begingroup$ The workaround that could work is sculpting from inside of mesh, thus making the opposite effect of usual sculpting. Try to sculpt with different brushes continously on such region. Also I don't think deleting polygons in Edit mode on sculpted model is a good way because it can damage other sculpted regions. $\endgroup$ – Mr Zak Mar 22 '16 at 22:08
  • $\begingroup$ I tried massaging the mesh from the inside and it did help, although it required a few tries to get it right - scraping inside makes the bubble go outside and then you have to scrape it from the outside, but finally the mesh gets nice and smooth, thank you. $\endgroup$ – jubi Mar 24 '16 at 10:59
1
$\begingroup$

You should be able to fix this with the smooth brush. Just go over the required area and it should get rid of the bubble. Just be careful to not set the strength of the smooth tool too high. Otherwise the flatten brush will help to. To stop this from happening in future you can use the mask brush to paint the area you don't want to affect.

$\endgroup$
0
$\begingroup$

Your modeling workflow should be meant to avoid such artifacts, placing the points by hands, then subdivide and scult again until each level is perfect so that you don't get to this point

$\endgroup$
  • $\begingroup$ I suppose you are talking about Multiresolution sculpting, while what I'm using is Dyntopo sculpting. There is no need to subdivide anything in Dyntopo mode because there is no such thing as global detail level in this mode. $\endgroup$ – jubi Mar 24 '16 at 9:36
0
$\begingroup$

Using Dyntopo can get very messy if not done with caution, looks like the mesh is highly subdivided at this area, smoothing it will help little, since the distance in between vertices is too small, and there are lots of them, in this case I would use "Subdivide Collapse" in Dyntopo, set the details to a level to give similar resolution as the area surrounding the problematic area, then slightly touch it with a sculpting brush "other than Grab and Smooth" usually Clay brush will do fine, this will decrease the mesh resolution significantly, then use the Smooth brush, and this area will be corrected easily.

Consider enabling wire view in order to see the density of your mesh while working with Dyntopo, and since I mentioned Grab brush earlier, for some weird reason, Grab brush never worked for me while Dyntopo is enabled, I don't know if this is a bug or that's the way it should be, just keep this in mind when using Dyntopo.

Since you're using Dyntopo, I believe you already know that Dyntopo details level is related to the view, I believe it's in pixels, and relevant to your screen size, this is why zooming in or out while sculpting, will give different resolution results, it's always a good practice to keep the same approximate distance from your object while using it, otherwise you need to adjust the details level after zooming in and out.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.