8
$\begingroup$

I have imported a 337 MB mp4 video file with no audio into Blender. In Blender, I am primarily just adding audio and then rendering back out to mp4. However, the rendered video quality is drastically lower, making much of the text in the video unreadable. The size of the output file is 65.7 MB.

In this image you can see my output settings: enter image description here

Can anyone tell me what I am doing wrong? How can I get a higher quality render to mp4?

$\endgroup$
5
$\begingroup$

You should increase the bitrate. It determines the compression of the video data.
A starting point could be to set the bitrate as least as high as in the input file, and then add the Mp3 rate of 192kbs.

1920 x 1080 = 2,073,600 pixel count 
24 frames per second 
4 = High Motion 

(2,073,600 x 24) x 4 x 0.07 = 13,934,592 bps / 1024 = 13,608 kbps bitrate

See sections 4 (Quality versus Streaming) and 5 (Starting Points), in this tutorial.

$\endgroup$
  • $\begingroup$ Also remember that Blender's encoder perfoms compression as a single pass and may not yeild the same result. $\endgroup$ – David Mcsween Nov 17 '13 at 9:32
  • $\begingroup$ Following your formula I came up with a bitrate of 17,010 for an imported video of 1920x1080 at 30 fps. In Blender, I changed the following settings: Bitrate: 17010 Minimum: 15000 Maximum: 17010 The output video has whopping 624 MB file size, which I would be fine with, but the blurry rendering remains unchanged as far as I can tell. $\endgroup$ – Darren Nov 17 '13 at 17:06
  • $\begingroup$ Also, I forgot to mention that the total bitrate of the source video that was imported into Blender is 8138 kps. $\endgroup$ – Darren Nov 17 '13 at 17:15
  • $\begingroup$ @Darren strange, if you're happy with input files quality with a higher bitrate the output quality shouldn't be diminished. You could lower the GOP (uncompressed keyframes) a bit and check the result. Otherwise I would choose a different format (at least for testing). $\endgroup$ – stacker Nov 17 '13 at 17:38
  • 1
    $\begingroup$ Ok, it looks like I am part of the way to solving the problem now. I overlooked the "Percentage scale for render resolution" setting. This was set to the default of 50%. After putting this to 100% the problem indicated in my initial post is now solved. However, now there is this strange pulsing that occurs approximately every second. During this "pulse", the video seems to move to a much lower quality and then quickly returns to a high quality. $\endgroup$ – Darren Nov 17 '13 at 17:48
3
$\begingroup$

I had the same problem. The input video was of decent quality, but the output had an evident encoding problem resulting in bad quality.

The strip containing the video was starting before the frame 0. I can only presume that was causing the problem because after I hard cut the strip (instead of a soft cut) at a positive frame, the video was encoded just fine.

I'm a noob with Blender, so this is just my guess: Perhaps the input video was decoded starting from frame 0, producing an error on all following frames.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.