0
$\begingroup$

I am working on 3 objects: eyes, face and chest armor.

I have them on different layers and each one has a separate material and UV map. I have texture painted the eyes/face and when I switch to the UV mapped chest area and try to texture paint, it automatically switches the UV map to the one I used for the face and has the face texture on the chest.

If I switch to the UV map view and try to change the texture image to the blank chest one, it doesn't actually change on the model. I've tried setting up the nodes in cycles to assign the UV / texture I want to paint to, but it still stays at the face texture on the chest.

I'm sure I am missing a step / not setting it up right. What do I need to do? Thanks.

Here are some images to help explain better:

This is the UV map and texture I want it to use: The UV map and texutre I want to use

And this is the UV map and texture it auto applies: The UV map and texture it auto applies

$\endgroup$
1
  • 2
    $\begingroup$ Instead of editing the question you can mark your question as solved by accepting the answer that helped you. $\endgroup$
    – PGmath
    Commented Mar 23, 2016 at 15:14

2 Answers 2

2
$\begingroup$

sharing some pictures and the .blend file could help a lot (since i don't have enough rep to comment your question i said it here)

anyway i show you the steps hope it helps:

first you have to set up a few different uv maps:

enter image description here enter image description here

one for the texture and a few more for sides, back, top, etc.

you can use ALT+B to cut the mesh so you only select the vertices that are visible from that angle

like this enter image description here

then align the uv with pictures you want to copy from

enter image description here

after that go to texture paint mode and create a texture for the face

(explained in the picture) enter image description here

hope it helps

$\endgroup$
3
  • $\begingroup$ and also be sure to save the face texture (or any other) after you create it otherwise you lose any painting you did (i have lost hard works before cuz of this not saving) $\endgroup$
    – Mohammad
    Commented Mar 22, 2016 at 22:54
  • $\begingroup$ Oh, you beautiful person! Thanks so much, changing those two sections on the "Slots" tab is what I needed! $\endgroup$
    – ORYG1N
    Commented Mar 23, 2016 at 13:17
  • 2
    $\begingroup$ @ORYG1N you're welcome, well if my answer was useful hitting that tick mark next to my answer is appreciated :) i want to get enough rep to comment $\endgroup$
    – Mohammad
    Commented Mar 23, 2016 at 13:50
-1
$\begingroup$

In the tools settings panel you can change the painting mode to image which is compatible with cycles.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .