0
$\begingroup$

Sorry for asking so many questions about this one project, I'm sure many of you have seen it a lot already. This should be the last one for this :P Thank you all for helping so much already !

Anyways, I'm almost done my little project, here it is in it's current state:

enter image description here

Everything goes pretty well-- except the pants, as is evident.

Here is the blend:

The pants have a cloth modifier on them with the Quality slider turned up to max (as that helped with this issue previously when the pants were at rest. Not the case right now). I've tried playing with the presets to no avail. The pants are pinned at the waist and ankle through pinning via a vertex group. The pants are also parented to the character to keep their offsets to it.

How can I fix the melding issues with the pants?

Edit: Tried removing the cloth modifier, but the leg still doesnt seem to collide with the body despite both having collision physics... Hrm.

Edit: Tried turning up quality on collision, no improvement :(

$\endgroup$
  • $\begingroup$ I spotted one of the problem was that you didn't apply the mirror modifier(try checking that out in edit mode), there are two pants on that guy, and try pinning some more vertices around the legs to give a bit more of control to follow the legs. Hope it helps! and by the way why don't you try generating a rig thought it is comparably simple model that you're doing. $\endgroup$ – bzal Mar 22 '16 at 3:45
  • $\begingroup$ Thanks for spotting those two obvious issues >.< I applied mirror, removed the extra mirror on the pants and added some more pin vertices on the pants-- however... not a lot of progress :( $\endgroup$ – elemein Mar 22 '16 at 3:57
  • $\begingroup$ should the the cloth be simulated as a soft body? if not, you would always weight paint to make it follow the mesh. $\endgroup$ – bzal Mar 22 '16 at 6:45
1
$\begingroup$

Ok, I just did a simpler rig now the answer is which is not very certain that I could only figure out there must be something wrong with how you adjusted the armature and the pinned vertices most probably won't move so the leg that's kicking is something you need to unpin like:

enter image description here

make sure you enable the cloth simulation on the physics tab ONLY FOR THE CLOTH(PANTS) and the collision set only for the mesh. and hence the result:
enter image description here
(this is a simpler rig though.)

$\endgroup$
  • $\begingroup$ I have removed the pinned vertices on the kicking leg, removed all physics, added collision to the character, cloth to the pants, and turned quality to max... And still the problem persists :/ Is my rig the issue? Im not understanding why you can get clean results for what Im doing and I can't $\endgroup$ – elemein Mar 22 '16 at 15:11
  • $\begingroup$ Can I have that blend file so I can see the differences? :o $\endgroup$ – elemein Mar 22 '16 at 18:00
  • 1
    $\begingroup$ Figured out the issue. $\endgroup$ – elemein Mar 23 '16 at 1:45
  • $\begingroup$ Well what was the issue, sorry I couldn't provide the .blend $\endgroup$ – bzal Mar 23 '16 at 1:54
  • 1
    $\begingroup$ On the character I put the armature modifier before the collision modifier. Switched them around, 90% of poke through went away >.< Well that was easy. Still have a bit to go but its bearable now. $\endgroup$ – elemein Mar 23 '16 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.