1
$\begingroup$

Here is something I made:

enter image description here

It is a mesh I made and rigged and posed and such into a little 11-frame animation meant to play at 10 fps to last a second.

I have two quick questions.

When I click then "Render" animation button in the scene menu, the output is weird as heck. It gives me about 60 black images in my folder, despite the camera pointing to the rig and the animation only being 11 frames long (marked on the timeline too.) How can I make it output my 11 frames?

Thanks!

Edit: I tried using OpenGL viewport mode and the animation works fine there.

Edit: My question isn't a duplicate. The answers in the other question do not solve my question.

Edit: Another user told me to upload the file:

$\endgroup$
  • $\begingroup$ While your questions are well-worded and clear, I suggest asking them as two separate posts. This allows people that specialize in dealing with the sorts of problems you're encountering help you better. 1. Sounds like you need to preview your rendering with a single image before rendering a bunch of them. 2. Look up the different interpolation modes, you can access them in the graph editor. $\endgroup$ – Mike Belanger Mar 21 '16 at 23:16
  • $\begingroup$ Alright Ill repost them separately. $\endgroup$ – elemein Mar 21 '16 at 23:34
  • $\begingroup$ Cant even get to step 2 of that post :( The output images are just grey. $\endgroup$ – elemein Mar 22 '16 at 0:03
0
$\begingroup$

Your main object is disabled for rendering. Enable the camera icon and render.

enter image description here

$\endgroup$
  • $\begingroup$ Huh... Guess that teaches me not to keep things tucked in their minimized state for too long! Aha thanks! $\endgroup$ – elemein Mar 22 '16 at 1:56
2
$\begingroup$
  • Make sure you have a light source bright enough in your scene.

  • Check your compositor and make sure that the scene output is wired into the final image (I think it's called composite, I'm not sure, I'm writing this on my phone).

  • Next, to solve your problem with 60 images instead of 11, go to properties, and click on the camera icon. In the first or second section should be a drop-down menu for the frame rate. Click on custom and type "10" for your frame rate.

Also, make sure your actual animation is only 11 frames long in the timeline. Check your file output settings too. Other than that, I don't know what could be causing those black frames.

$\endgroup$
  • $\begingroup$ I definitely have a bright enough light source, I haven't touched anything to do with a compositor (or anything to do with those node things) and thanks for the last tip :) $\endgroup$ – elemein Mar 22 '16 at 0:30
  • $\begingroup$ Do you still have black frames? $\endgroup$ – Stefan Mar 22 '16 at 0:44
  • $\begingroup$ Yes, I uploaded the blend file. $\endgroup$ – elemein Mar 22 '16 at 1:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.