0
$\begingroup$

The shape I made consists of several hundred cubes (generated via Python), with some stacked on top of others, and all joined into one shape using Ctrl+J.
However, if I attempt to slice it using Skeinforge/ReplicatorG, it says that there are "dangling edges".

Is there any probable cause of these "dangling edges"? I have tried all of the Mesh > Clean up tools, but to no avail.

Thank you!

Here's a part of what the mesh looks like so far:

enter image description here

Edit: here's the .blend file:

$\endgroup$
  • 1
    $\begingroup$ Did you select all geometry before proceeding to Mesh > Clean-Up tools ? Aside from that I think you should post some screenshots of mesh/-es in Edit mode and upload the file. $\endgroup$ – Mr Zak Mar 21 '16 at 20:47
  • $\begingroup$ Welcome to the site. You might want to take the tour and review the help center. To provide for the best chance at getting help, you might want to post a copy of your ~. blend file to a site like Blend-Echange, and edit a link into your question. $\endgroup$ – brasshat Mar 21 '16 at 20:47
  • $\begingroup$ @MrZak, I believe I did. Thank you for your advice; I posted a screenshot and uploaded the file. $\endgroup$ – 416E64726577 Mar 22 '16 at 2:01
2
$\begingroup$

Terminology may vary, but what Skeinforge/ReplicatorG is calling "dangling edges" refers to one specific type of non-manifold geometry. It is the kind where an edge is shared by more than two faces. In other words, this is bad:

Non-manifold geometry: An infinitely thin edge

It is an infinitely thin shared edge, because even though each cube has a volume, they are joined in a way that is impossible in physical reality. Imagine if you were to perfectly line up two tables so that their corners touch in a similar way - would you have one table or two? You would still have two tables, of course. With this kind of non-manifold geometry it would be analogous to having the tables inseparably stuck together at the corner where they touch, even though they are only connected by a few molecules. A 3D printer doesn't know what to do with that.

Here is another example - infinitely small corners. Or if you prefer, "dangling vertices".

Non-manifold geometry: An infinitely small corner

So what are your options? Well, you can either separate them:

Cubes separated

Or you can create a very small area where the cubes touch that joins their volume:

3D-printable edge connection

3D-printable edge connection:

3D-printable edge connection close-up

3D-printable corner connection:

3D-printable corner connection close-up

Now that you understand the nature of the problem, your challenge will be coding into Python a new way of generating your geometry that is manifold. Have fun. :-)

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks so much for the explanation! When I keep this in mind, everything works perfectly. $\endgroup$ – 416E64726577 Mar 22 '16 at 23:04
  • $\begingroup$ @416E64726577 Glad to hear! Happy blending. $\endgroup$ – Mentalist Mar 22 '16 at 23:10
1
$\begingroup$

Revised Answer

I downloaded and examined your ~.blend file, and then read your question more thoroughly. I think there is an issue with the way you constructed your "shape of cubes". Generating cubes in Python, and joining them with CTRL-J will generate a large number of duplicate vertices, edges, and faces. After downloading your file, when I attempted to select non manifold edges, using CTRL-SHFT-ALT-M), nothing was selected. After removing doubles—the report was 22641 vertices removed—and attempting to select non manifold edges, most of the object was selected. Since this is for 3D printing, the interior vertices may be an issue, too. If it were me, I'd look for an alternative method for building your initial mesh, perhaps one based upon extrusion that does not generated unnecessary internal geometry, or alternatively, add logic to your script that would merge vertices together, where appropriate.

Original Answer

In the absence of a ~.blend file, one thing to try in edit mode, choose face select option, limit selection to visible, and using circle select tool, highlight all faces you can see, and hide them with the H key, rotating the scene so you can select from all views . If you do this repeatedly, you may see edges or vertices which are not part of faces, and be able to select and delete those.

| improve this answer | |
$\endgroup$
  • $\begingroup$ @Mr Zak, if there is an unintended edge between one vertex through the center of the cube to the opposite vertex and one uses CTRL-L, this edge will not be isolated. Doing the select-faces-and-hide method does isolate such edges. $\endgroup$ – brasshat Mar 22 '16 at 1:35
  • $\begingroup$ It won't be, but it will be detected with Select Non-Manifold operator (and loose geometry too). However this won't help with the problem in the question. $\endgroup$ – Mr Zak Mar 22 '16 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.