3
$\begingroup$

I'm having the issue where the rifigy properties and layers are missing, however the normal solution mentioned here does not work:

Rigify rig main properties and rig layers disappeared

I was editing bone constraints and perhaps i accidentally altered the constraint on a rig which i undid. But i recall that being one of the last things i did before i noticed the problem.

Here's the file with just the rig in it. No model needed to demonstrate the problem.

>>Problem Rig file<<

How could i get the menus back while keeping my current rig intact?

$\endgroup$
3
$\begingroup$

This particular problem was caused by deleting the rig_ui.py file and replacing it with the rig_ui.py file generated in a different file. The rigify plugin creates and executes the script which is partly specific to the rigify rig that it's generated with. It's found in the scripting tab.

The problem is solved by going to the scripting tab, and checking a specific line in the 'rig_ui.py' script.
On line 6, where it says 'rig_id =' there should be within quotes, a specific code that should match the code found on your rig.

To find your rig's ID, select your rig and check the rig properties. Underneath 'Custom properties' copy the 'rig_id' code. Check to see whether it matches the code mentioned in the rig_ui.py script. If it doesn't match, that's the problem, so delete the code inside of the quotes. Paste in your rig's ACTUAL id in the code, inside of the quotes next to 'rig_id ='.

Now hit 'Run script' on the toolbar below and the buttons on the N menu should return.

| improve this answer | |
$\endgroup$
  • $\begingroup$ i have the same issue, but even if doing the above, nothing helps. I even made a new blender file, just added a metarig and hit generate. The "Rig main properties" is always empty. I can see the tab in Pose mode, but it's always empty. Where is it supposed to be? $\endgroup$ – Niclas Feb 10 '17 at 20:26
  • $\begingroup$ is there a smart way to do this for multiple characters? I have 5 characters liked in the scene, I don't want to keep doing this manually for each one of them separately. $\endgroup$ – Ahmed Ali Apr 1 '18 at 9:44
  • $\begingroup$ Where else can I find rig ID but not the underneath ‘custom properties’?? $\endgroup$ – kato May 20 at 7:51
  • $\begingroup$ I found that I just need to add rig_id properties and put ID from python at the properties value. Same like other fine rigs. $\endgroup$ – kato May 20 at 8:42
0
$\begingroup$

I found out that rig_id is pretty finicky with the names you might try changing some things about the name and rerun the script to see if that fixes your problem. On Blender 2.79, having the word "rig" anywhere in the ID name would cause the script to fail (no N menu) without warning. That is not the case in Blender 2.81 however: if you put a Capital letter like "A" instead of "a" anywhere in the name, the Ik_FK snapping options become unavailable. you only get the Ik_FK blend slider under Rig Main Properties and nothing else.

So, play with the naming, keep it simple see if that helps.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.