I'm trying to create a displacement texture. However the texture is appearing too small on object.

How do I fix this? I began by subdividing the plane multiple times and then added displacement texture. enter image description here

enter image description here

  • $\begingroup$ You are using "repeat" mapping, with crop maximum x/y values of 10. Is it better if you set both to 1? $\endgroup$
    – m.ardito
    Mar 17, 2016 at 15:53
  • $\begingroup$ You'll make it easier for those who might wish to help you if you post a copy of your ~.blend file to Blend-Echange, and edit a link to the file into your question. $\endgroup$
    – brasshat
    Mar 17, 2016 at 20:02

2 Answers 2


Displacement map made with procedural textures

Switch to Textures panel in order to open texture used by Displace modifier. You will find different options which vary depending on texture type. The Size option is accessible for many of them which is one you need if you work with procedural textures.

procedural displacement map settings

Image textures

If you have image texture, I'd suggest changing texture coordinates which use Displace modifier.

  1. In modifier's panel, Texture Coordinates option, change it to Object.
  2. Add a simple plane somewhere nearby, choose it as object in mentioned option.
  3. Now to scale image which is used as displacement map scale that added mesh. Displacement map will be resized according to that:

image texture displacement map sizing

  • $\begingroup$ Instead of a Plane, you can also use an "Empty" $\endgroup$
    – daleyjem
    Jun 7, 2019 at 4:13

Under the 'Image Mapping' tab, change the crop maximum to: X: 1.00 Y: 1.00

  • $\begingroup$ I have just tied that it didnt make it bigger $\endgroup$ Mar 17, 2016 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .