5
$\begingroup$

This is one of the most annoying things while sculpting with Dyntopo enabled - it switches itself off automatically for various reasons eg. going from sculpt mode into object mode and then back into sculpt mode or undoing too far, to the state of affairs where Dyntopo was disabled.

I had to redo so much sculpting when I realized that nothing suddenly went wrong with my mesh but that I forgot to re-enable Dyntopo that it becomes a major pain. I am aware of the Ctrl + D shortcut to quickly enable Dyntopo, but it just too easy to forget about re-enabling it.

Is there a way to keep Dyntopo enabled by default or prevent it from switching off, maybe at least with some clever Pythong scripting?

$\endgroup$
5
$\begingroup$

This problem has finally been noticed by Blender developers and included in 2.78 release.

"Enable dyntopo re-entering sculpt mode" https://developer.blender.org/D2059

Dynamic topology will be re-enabled automatically when entering sculpt mode, but only if uv's, vertex colors or triangulating won't be affected.

$\endgroup$
-1
$\begingroup$

You cannot because of the way the code is. When you are going out of Dyntopo, Blender has to synchronize you data, your Dyntopo sculpt, with the rest of Blender.

Or should I say you could change it if you were willing to code it?

$\endgroup$
  • 1
    $\begingroup$ This is a good answer, but it could have more information. Could you describe why it was coded the way it was? Could you add sources for your information, so others can do more research? $\endgroup$ – Matt May 19 '16 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.