I'm rendering a movie in cycles.
When I'm rendering an object (2 objects copied with AltD), a part of the mesh disappears, determined by angle of the camera.

it acts like a render border, but it only effects a "vertex group" of the mesh. The mesh doesn't has any actual vertex groups. Or any of that kind (looked at mesh-data in the Properties editor). I can't find any strange settings.

This is shown in the render view as well as in the viewport. And only when it shows the render view. I tried the internal render. But then the whole render is inexplicable

I can't give a picture of the problem, because I have confidentiality. and can't reproduce the problem because I don't know how it came there.

(blender version is 2.66 or 2.69, same problem on like 30 computers (just with the 0, but its coincidence), re-saved with new name multiple times

  • 2
    $\begingroup$ Could you give a screenshot of your materials at least? As it is now it's almost impossible to tell what it might be without any idea what the problem even looks like. $\endgroup$
    – gandalf3
    Nov 14 '13 at 18:50
  • $\begingroup$ Are you having artifacts like this across your mesh? puu.sh/5ir03.png $\endgroup$
    – CharlesL
    Nov 14 '13 at 21:34
  • $\begingroup$ There was a bug that affected 2.67 and 2.68 where a muted bump node fed bad results causing a material to be invisible, with the affected area changing with camera angle. Any chance you have a muted node in the material? use any normal maps? fresnel/light path/layer weight nodes? $\endgroup$
    – sambler
    Nov 15 '13 at 11:06

This is a bit unlikely because your mention of "vertex group", but a problem most similar to "render border" is when active camera's Clipping distance is too limiting for the scene's size. For example, the following scene is using default camera:


Lower-right object is of regular size, and intersects the camera's Start/near clipping distance. While upper-left object is 10 times larger and bumps into the camera's End/far clipping distance.

If this is the case, relevant settings you need to adjust are in Properties window > Object Data tab > Lens group for the camera object.



I've solved it.

what went wrong is still a mystery, but I want to thank you all.
Copying the original vertices is what went wrong. The solution was to delete the old one and set the new one to it.

A really dirty fix. but it worked.

the reason that the suggestions couldn't be it:

  • Solution gandalf3: materials were also at other objects. but those where visible

  • Solution CharlesL: couldn't be it because the problem looked different

  • Solution sambler: there where no bump nodes used. Only standard shaders. (mix shader/diffused/glossy/transparent(not where the problem occurred)/glass) also this is not one material, its a combination. Besides that, when you move your view a part of the face is still seen.

  • Solution Adhi: can't be that because there where objects in front of the problem object and behind the problem object. Those rendered just fine. and there is no compositing used, just 1 image.

But still allot of respect for you're effort. This is my first experience of posting a problem online and it was a very positive experience. :)

I'm trying to get the images or the video online, but can't promise it.
This is what happens if you turn the camera view in 3D:

In this model the situation is: the blue stays visible no matter what view, the rest is cut.
Color is delimited by material. blue could be the same material as red grey or yellow. It is only 1 object. This could be in a environment the rest won't be affected.

first angle of the simulation object

second angle of the simulation object

The version 2.69 was a RC version, but the problem occurred before I used this one.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.