0
$\begingroup$

The blender model when rendered as an image or animation through the top menu bar doesn't display most material and light elements. (image 1)

Although when viewing the model thought the view-port at the bottom of the stage as a render preview, it show all the correct lighting and material elements. (image 2)

I can't seem to find the setting/s to enable all materials and lighting effects to be displayed during rendering via the top menu bar.

enter image description here

$\endgroup$
2
$\begingroup$

Managed to find the issue.

Under the render layers tab, there is a material override option, that replaces all materials with only one. My issue was fixed when clearing this material option.

enter image description here

EDIT:

Newer versions of blender don't use layers, but "collections" so the override function is in the scene>View Layer section.

enter image description here

Additional info:

Where is the Layers panel in Blender 2.8?

2.8 - Is it possible to assign (override) a material to a whole collection?

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.