I am using blender 2.66. I have added a text object and then selected the Object tab in the properties window, went up to the bottom and the used object color picker to choose a color.

But even after choosing a color, when I render the scene as image the color does not seem to be applied to the text object. Is there anything I am missing?


1 Answer 1


Try creating a material.

Blender internal:

  1. Create a material in Properties > Materials panel:

    > Add new

  2. To simply add some color, you probably want to set the Diffuse color instead of the object color:

    in the Diffuse panel

Object color only affects the render when enabled in Material > Options:

Object color

Object color is used to add some color variance per object without adding new materials.


AFAIK, Object color is not used at all in cycles.


To give an object a color in the render for cycles:

  1. Create a new material in the Materials panel by pressing Add new:

    > Add new

    This will automatically add a Diffuse shader.

  2. Adjust the Color input of the diffuse shader:

    enter image description here


To give the object a color in the 3D view set the Viewport color in Properties > Materials > Settings > Viewport color:

enter image description here

Note that the Viewport color is separate from the colors defined in the material which will appear when rendered. (It will only affect the 3D view)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .