2
$\begingroup$

I have two objects I am trying to paint with two different materials. I'd like to sample from the viewport in order to maintain color choice, but cant do so -- it always tries to sample from the texture I'm currently painting on. The same goes for layers, it won't let me sample the layers below.

Is there an option to change this? A hotkey to tell it to sample from the viewport?

$\endgroup$
1
$\begingroup$

The hotkey is S.

It functions two ways, by holding S the current paint colour will be set to whatever is under the cursor. By clicking RMB RMB while holding S a new swatch will be added to the pallette. (see the end of these release notes)

$\endgroup$
1
$\begingroup$

In Blender 2.77, enable the "Sample Merged" option. Available in the operator properties.

If you want you can assign a shortcut for this, though we may make this Shift-S in future releases.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.