1
$\begingroup$

I'm trying to create a simple scene like the scene depicted in the answer here:

enter image description here

I reproduced the Compositor and Volume scatter settings, and this is what I get when I render:

enter image description here

But in the Rendered viewport, the scene looks somewhat closer to what I'm trying to do:

enter image description here

I've tried branched path tracing and path tracing, I tried rendering without Compositing enabled, tweaked various settings, and read many questions on Blender SE about light rays but can't seem to understand why it won't work...

Blend:

$\endgroup$
  • $\begingroup$ It's working, you just need some strong gpu to render it. Here I colored the light, cranked it to 50k strength and rendered: i.stack.imgur.com/DtQv5.png $\endgroup$ – Jaroslav Jerryno Novotny Mar 10 '16 at 12:37
  • $\begingroup$ Bring up the light bounces for volume in the light paths section. Also try a lower value for volume scatter. $\endgroup$ – cegaton Mar 10 '16 at 15:25
  • $\begingroup$ @Jerryno with what rendering settings? I get something completely different with 50k light. cegaton where is "light paths section"? Lower value in volume scatter's "density" or "anisotrop"? Is this how you produced the first image in the question? $\endgroup$ – MicroMachine Mar 11 '16 at 0:51
  • 1
    $\begingroup$ @fabriced here's the file form the original post: <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=1102" /> $\endgroup$ – cegaton Mar 14 '16 at 16:06
3
$\begingroup$

There is object named Plane.002 which is visible in rendering but not viewport. That's the culprit.

Hide it from render and you will get the same result in viewport and render.

$\endgroup$
  • 1
    $\begingroup$ O-M-G you're absolutely right! Noob mistake. Thanks. $\endgroup$ – MicroMachine Mar 11 '16 at 9:59
0
$\begingroup$

I'm not a blender expert but it seems as though you don't need the volume scatter or you don't have enough light in the scene. Are the light sources on the same layer or a different one? My question only matters if you might have turned on "This layer only" in the light settings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.