2
$\begingroup$

This question already has an answer here:

I'm trying to fade out an object by using a transparency BSDF. With Transparency set to 0 it looks like:

Transparency set to 0

When turning the transparency up to 100% to get the structure opaque I get this result:

Transparency set to 100

I have no idea where those dark areas are coming from. The mesh I'm using has been imported from an obj file and was originaly created with a CAD software. I have tried to recalculate surfaces and removed all doubles, but I'm still getting those dark areas.

As I want to use it in an animation I think I could turn up transparency and just before it should go 100% transparent I'd set a keyframe on Restrict Rendering in Object Explorer, but I think it still might look a bit "harsh".

Does anyone has an idea, what could be wrong?

Thank you!

$\endgroup$

marked as duplicate by gandalf3 cycles Mar 9 '16 at 22:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ Under your Material Panel >> Settings >> Surface... Is your Transparent Shadows option checked? $\endgroup$ – Rick Riggs Mar 9 '16 at 22:39
  • $\begingroup$ Yes it is checked. Sorry, forgot to mention that. $\endgroup$ – Seb Mar 9 '16 at 22:53
  • $\begingroup$ There is a mix shader with an unconected socket, could that be causing so sort of trouble, vene though the next mix node is ignoring it? $\endgroup$ – Duarte Farrajota Ramos Mar 9 '16 at 23:56
  • $\begingroup$ Gandalf3 is right. His question "Black artifacts when looking through many transparent objects?", is about the same problem. Thanks for the help and sorry for the duplicate. $\endgroup$ – Seb Mar 10 '16 at 8:09

Browse other questions tagged or ask your own question.