3
$\begingroup$

In physics, I am experiencing some faster-moving objects falling right through the floor. Most other objects land/bounce/etc. appropriately, but the fast-moving ones just fly right through the ground. How can I prevent this?

$\endgroup$
2
$\begingroup$

I solved my rigid body physics “falling through the floor plane” problem by raising: Scene > Rigid Body World > “Steps Per Second” and “Solver Iterations” above their default levels of 60 and 10. This scene has 10,000+ fast-moving cube objects. At default levels, over 100 objects fell through the floor plane. At 5 times the defaults, (300 and 50 respectively), only 3 objects fell through the floor. At 10 times the defaults (600 and 100), NOTHING fell through the floor. The calculation took longer, but was probably generally more accurate than with default Steps and Iterations levels.

$\endgroup$
1
$\begingroup$

Assuming you are using rigid body physics:

  1. Make sure the ground plane's physics is set to passive.
  2. If it is still glitching, add a solidify modifier to the ground plane.
  3. If it is STILL glitching, then set then set the rigid body collision shape to box on the ground plane.
  4. Still glitching? enable the collision margin on the ground plane and mess with the margin size.
  5. If the problem persists, change the collision shape of the faster-moving object to box as well.

Hope this helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.