1
$\begingroup$

I am trying to render my Images in GPU Computer but after 1 Minute or so this message pops up:

OpenCL build failed: errors in console.

Now whats with that? Anyone experiencing that as well?

Working on: MacBook Pro (Retina, 15-inch, Late 2013) 2.3 GHz Intel Core i7 NVIDIA GeForce GT 750M 2048 MB

$\endgroup$
  • 3
    $\begingroup$ As the message says, did you checked the console? $\endgroup$ – Antonio Buch Mar 2 '16 at 18:51
  • $\begingroup$ BTW as far as I can see, your card is compatible with Cycles $\endgroup$ – Antonio Buch Mar 2 '16 at 19:05
  • $\begingroup$ Check that the drivers for your GPU are up to date. Try Re-installing them $\endgroup$ – cegaton Mar 2 '16 at 19:07
  • 1
    $\begingroup$ What is the error message in the console? $\endgroup$ – cegaton Mar 2 '16 at 19:08
  • $\begingroup$ @SebastianJaeger to access the console please read: blender.org/manual/interface/window_system/… $\endgroup$ – cegaton Mar 2 '16 at 20:37
1
$\begingroup$

As I just investigated in https://developer.blender.org/T48842 - if no errors was really produced (despite msg "errors in console. ") try to run blender with "--debug-memory" option - it enables "fully guarded memory allocator" which magically does things.

$\endgroup$
0
$\begingroup$

Nvidia Graphic Cards don't really work with OpenCL on OSX.

You have to install CUDA, restart Blender and chosse in the

User Preferences --> System --> Compute Device --> GPU

CUDA.

Then it should work.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.