1
$\begingroup$

enter image description here

So I rendered some 1000 frames. It took a while. The noise is a bit too high and now I want to reduce it with bilateral blur node ,but it is not working correctly.

The frame sequence works as an image input, but the Render Layers node doesn't change anything a bit.

Tried all sorts of things, but the Determinant value does not react. No result changes.

I am probably doing something wrong. Any ideas?

Thanks!

$\endgroup$
  • $\begingroup$ Did you pressed F12? It looks like you'd never render that Render Layer before. Without rendering, there is no information to make your Determinator .Maybe is just collapsed, I'm guessing. $\endgroup$ – Antonio Buch Mar 2 '16 at 13:26
  • $\begingroup$ I rendered it on another PC, all I got is PNG image sequence and the file I sent to rendering, F12 just displays the image sequence from the Video Editor, where they are imported. $\endgroup$ – Krišjānis Zariņš Mar 2 '16 at 13:30
  • $\begingroup$ Ok, I think I got it. Just for checking, please press the render button of the Render Layer node. It's the one at the right-bottom corner. Tell me if you can see your Bilateral Blur working in composition. $\endgroup$ – Antonio Buch Mar 2 '16 at 14:09
  • $\begingroup$ As I understoot, I need to rerender everything even on low samples to acquire the Z and Normal values? Or more samples are needed here? $\endgroup$ – Krišjānis Zariņš Mar 2 '16 at 14:13
  • $\begingroup$ Yes, but not only that. Did you try what I said? Another question, is your camera moving? $\endgroup$ – Antonio Buch Mar 2 '16 at 15:27
2
$\begingroup$

The Sequencer overrides all

Your main problem here is that you have the rendered image sequence in the Sequencer.

The Sequencer overrides the Compositor, and the Compositor overrides the 3D scene. So, if you have a camera into the 3D scene, it won't render if you haven't a Render Layer in the Compositor. Likewise, if you haven't a Scene strip in your Sequencer, it won't render the 3D scene, neither the composition nodes you have.

In this case you only have the image sequence, so Blender is going to just render that strip, overriding the Compositor.

How to proceed

If you want to apply a Bilateral Blur on your rendered sequence, you only need the Compositor. So delete the elements in your Sequencer Editor.

Your composition is OK, just added the rendered sequence and applied the Bilateral Blur to it with the Z-Depth and Normal outputs as Determinator.

If you press F12 you'll see that the Bilateral Blur is working now.

Speeding up the process

When reducing noise after rendering, you can low your render settings, as you only need the Z-Depth and Normal passes.

To do this, you can decrease the render samples. Also I recommend deleting all the lights and disabling Use Environment checkbox under Render Layers tab. If you have emitter materials, put a simple grey diffuse as material override.

Doing this, you are rendering without lights, so Cycles works much faster.

Note that if you low the samples too much the contour of the objects in the Normal pass can be a little aliased. So keep the render at a minimum of 100 samples.

For this reason and for speeding up the render you can render in Blender Internal.

Concerns about Bilateral Blur after rendering

There is a last thing to have in mind, if you use the Bilateral Blur after rendering, you are going to blur the textures too. As you could see in the tutorials about noise removing, the Bilateral Blur is applied before Diffuse Color and Glossy Color passes which have textures on them.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.