1
$\begingroup$

I ve found weird limitation in Blender, how to avoid it?

There is a model with global coordinates in X and Y about 100km (kilometers) So in object mode transform location show us real values (100km) but in edit mode there is some limit to show - 10km (transform location shows us 10km maximum and it does not change when you move vertex if your global coordinates more than 10km) so I can't move vertex by typing in coordinate which value more than 10km.

Is that limit a bug or it can be turned off somewhere?

What to do if I need to set X,Y values of selected vertex in edit mode to (100002m, 99003m)?

$\endgroup$
  • $\begingroup$ Check out blender.stackexchange.com/questions/39386/…. Pretty much work in default blender units (the grid), the scale becomes arbitrary to fit your model. Eg your example coords could be (10.0002, 9.9003) in bu. Depends on LOD too I suppose. $\endgroup$ – batFINGER Mar 1 '16 at 8:24
  • $\begingroup$ Nope, no matter which units you use and scale units does not work here. E.g. if you set scale to 0.001 than coordinates change to (10m,10m) but they still be ''frozen'' while you moving vertex. $\endgroup$ – Stan von Zarovich Mar 1 '16 at 9:08
  • $\begingroup$ @StanvonZarovich What batFINGER is saying, is that you don't need to use units at such a large unit. Instead you could use dimensional values at a lesser scale for your whole scene (eg. 10.0002, 9.9003 or 1.00002, 0.99003). The point is: as long as you keep your units within a manageable range it all works. I typically work in decimal inches, however to keep things comfortable in Blender's default relationship to the grid floor, I often move the decimal place one to the left for everything that I model. $\endgroup$ – Rick Riggs Mar 1 '16 at 9:51
  • $\begingroup$ It doesn't work with existing model, Try to recreate the scene. Add a plane, move it to 100 000 units on X and Y. Then scale units to 0.001, go to edit mode and try to move any vertex by typing in 10.001 to its X global coordinate for example. $\endgroup$ – Stan von Zarovich Mar 1 '16 at 10:30
  • 1
    $\begingroup$ What, exactly, are you trying to do here? $\endgroup$ – brasshat Mar 1 '16 at 12:48
2
$\begingroup$

The limit is a function of the design of the software, and as far as I know, cannot be turned off. The maximum dimensions of an object are 20,000 blender units, that is from -10,000 to +10,000, in each axis. While in many cases, a blender unit is defined by the use to be equal to a meter, it need not be, and is sometimes defined to be another unit, for example, an AU, or a KM. Complicating the use you wish to use for Blender, there is also a minimum precision in Blender, in that the smallest units supported are -.000005 and +.000005.

How best to deal with the limitations posed by these design choices involves considering the use to which you intend to use your meshes.

$\endgroup$
  • $\begingroup$ I see, but this is weird, because dimensions of model 60x60m (units) it is just shifted 100 000 units from center and those limits in edit mode are for global system, not for local $\endgroup$ – Stan von Zarovich Mar 1 '16 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.