3
$\begingroup$

Is there a way to get the particles in the correct orientation to the emitter and not rotated at varying angles? (see image)

eg. butterflies sitting on a cube's surface.

My relevant settings are:

  • Emit From > Faces
  • Rotation > Initial Orientation > Normal
  • Render > Group > Rotation (selected)

v2.73

In the image example it looks like the normal interpolates between each adjoining face's normal to rotate the particle. I'm also noticing that when the object rotates the particles spin which is also an unwanted effect. Is the normal acting as the axis for a quaternion?

enter image description here

I cannot recreate this interpolation problem with a cube primitive (gives correct behavior) but when rotating the cube (emitter), the faces with the z-axis, causes the particles to move. cube created in v.276.

enter image description here

$\endgroup$
  • $\begingroup$ Its good that you have a question with a question mark (?) at the beginning of your statement. I do find the question to be unclear. Others may find it otherwise. I am suggesting you examine your question and make it more clear. [correct orientation] which you wrote could mean anything. I may make guesses in until that time. You have a group [panels] as particles, so that group could contain may different planes at different angles. You can tell the reader the contents of [panels] rather them encouraging them to guess $\endgroup$ – atomicbezierslinger Mar 1 '16 at 10:15
  • $\begingroup$ @atomicbezierslinger - edited for clarity. Ty $\endgroup$ – Eli Peters Mar 2 '16 at 13:43
  • $\begingroup$ Did you try any of the suggestions below? $\endgroup$ – atomicbezierslinger Mar 2 '16 at 15:56
  • $\begingroup$ I did try atomicbezierslinger suggestion and I couldn't get the desired or consistent results. But all results continued to have unwanted particle movement when the emitter rotated... might try keyed particles and post a result. $\endgroup$ – Eli Peters Mar 3 '16 at 11:29
  • $\begingroup$ @atomicbezierslinger - still got some weird particle movement with emitter rotation. $\endgroup$ – Eli Peters Mar 3 '16 at 12:49
0
$\begingroup$

enter image description here

Some Suggestions

  • I have experienced some latency and strange behavior with Particles. Yet I do not want to produce a defect report. Sometimes I have closed and reopened file. Move the timeline to frame 0 and switched from Vertex to Face to Volume emission. I have been very hesitant to inquire about this. I have felt this latency has suddenly function as expected. Misleading latency. Could be interpreted as superstitious.

  • For the text to mesh. Edit Mode, Use vertex remove doubles.

  • Object Mode, Remesh Modifier and Apply. So your faces are even size and no tedious hand modeling.
  • Edit Mode, With the faces from above in Faces Mode. Select all Faces. Sort Elements Randomize.
  • Note my Emission Panel Setting are a bit different than yours.
  • For the current settings and the simple scaled cube ... a rotation in EDIT mode can rotate the particle.

enter image description here

Image above shows the results of Remesh Modifier with Apply.

Other Edits May Follow.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.