1
$\begingroup$

I'm getting weird render artifacts around the edge of a cylinder on the floor, blocky areas that look low-res:

Blocky Texture Renders (Edit) Image A: Blocky Textures behind the cylinder

Rendering from other angles shows the same render artifacts. Seemingly around the render box intersecting both the cylinder and floor.

I've tried changing anti-aliasing and other settings with no effect.

Outliner and Render Settings (Edit) Image B: Outliner, Viewport, and Render Settings

I'm at a loss. Any ideas?

Other Info: Blender v2.76. Blender Render. This floor texture is rather large, 12.3 MB file and 4288 x 2848. But artifacts happen with other (smaller) textures as well.

$\endgroup$
  • $\begingroup$ You can use Blender or GIMP to create images that show more information to solve your problem ... multiple screen shots combined into one picture. I suggest you do that. Please show your outliner window to determine if there are more objects in the scene. $\endgroup$ – atomicbezierslinger Feb 28 '16 at 23:19
  • $\begingroup$ Check to see if in the Post Processing Panel for the Camera you are using the Compositor or VSE. If so turn them both off temporarily. $\endgroup$ – atomicbezierslinger Feb 28 '16 at 23:30
  • $\begingroup$ Good idea, I've updated the images. I turned off Compositing and Sequencer in the Post Processing in Render Settings and no effect. $\endgroup$ – Triad Feb 29 '16 at 0:18
  • $\begingroup$ Strange, creating a new cylinder and rendering that clears the artifacts. The issue must be in the original mesh data somehow. I'll let you know if I pin it down. In the meantime, here's the render with the fresh new cylinder: link $\endgroup$ – Triad Feb 29 '16 at 0:39
  • $\begingroup$ The artifacts are back. It happens at some point when I start unwrapping the object (marking seams, unwrapping, etc.) I wonder how unwrapping can cause this. link $\endgroup$ – Triad Feb 29 '16 at 0:54
1
$\begingroup$

The problem was: assigning a UV Map to the Cylinder was somehow messing up the floor's texture or UV Map. I don't know why. But I was able to clear the artifacts from the render:

I fixed it by selecting the floor --> Edit Mode, and applying a UV Map to it, via the left panel (Shading / UVs tab) --> UVs section --> Unwrap. So both the Cylinder and floor have their own UV Maps.

Unwrap the Floor

I don't know why changing the cylinder created artifacts on the floor; they are two different objects, two different UV Maps, two different materials, two different textures. But this solution worked for me!

Final Image with correct textures and no artifacts

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.