I use Blender to render objects as this makes them look better. The problem is when I export one of my characters as an OBJ file and then import it back into Blender to render, the textures seem to not have been saved with it and the character's surface appears pink when clicking on 'Texture Solid'.
At first I thought I accidentally pressed a button without realizing but, I sent the file to my friend and it was also pink for him so I began to think I was missing the texture. I have been scanning forums and found the suggestion of: File>External Data>Find Missing Files. However, this did not work either. I am completely and utterly stuck on what to do and my hobby is now hold up until I can fix it. The second image shows the problem I am having. The first image shows it's how some textures don't export with the file when I export the character from 'Roblox Studio'

Image 2 imported obj is pink enter image description here


.OBJ (Wavefront) file itself only stores geometry data, it does not keep anything regarding materials or textures.

Materials (including references [paths] to textures) are stored in companion .MTL file/format. But it does not embed textures themselves either.

So you have to give .obj, .mtl and all your texture files (you can use 'Copy' option of the exporter to copy all needed textures in a subdir next to exported .obj).

But there is yet another issue with OBJ - filenames must absolutely not contain any space. This is simply not supported by the format, and if your mtl and/or texture files have some, they won't get loaded.


When you export an OBJ, you have some options that need paying attention to...

'Write Materials' is most notable, make sure it is checked.

Try that 1st, if you are still having troubles, try changing your 'Path Mode:' to something else like 'Strip Paths', etc...

Once you exhaust these options, you shouldn't be having a problem, but if you are, at least the community here can help you a little more fast tracked, knowing what you have exhausted.

enter image description here

There are even settings on import, please verify that image search is checked as well:

enter image description here

  • $\begingroup$ Thank you for taking your time to answer my question. Where May I find these options? $\endgroup$ – Kye Harding Feb 29 '16 at 16:21
  • $\begingroup$ It should show up when you export / import (save/load) on the lower left hand corner of the screen. $\endgroup$ – Rick Riggs Feb 29 '16 at 16:33
  • $\begingroup$ All the import boxes are ticked. The problem i'm having is Importing the texture alongside the character. It worked perfectly fine for about 30 characters but now when trying to import them the texture no longer comes with it. I export the character from the a studio from a game. $\endgroup$ – Kye Harding Feb 29 '16 at 17:04
  • $\begingroup$ Do you actually have a .MTL file and supporting Image Files (usually in a folder of the same name)? $\endgroup$ – Rick Riggs Feb 29 '16 at 18:24
  • $\begingroup$ I'm starting to think it's either my computer or the Studio so I'm beginning to feel out of place. I literally went onto blender and uploaded an old file. If you take a look at my new image uploaded the characters on the right are old files where as the characters on the left are new files. And yes, when I export the characters from the Studio they do save with a .MTL file $\endgroup$ – Kye Harding Feb 29 '16 at 18:30

I also faced a similar issue. The issue is turned out in the .mtl file. it doesn't get map names correctly. enter map_Kd is not showing map name

I added my map name and then save the .mtl file. it's solved!! diffues map.png


Not the answer you're looking for? Browse other questions tagged or ask your own question.