0
$\begingroup$

I seem to have lost ability to select NVidia (and cycles renderer engine) after some hardware fixes (changes were made to replace components with same components, so in theory there should be no difference at all) and Windows updates. It was working long time before (I haven't had much time to play with Blender in last few months).

Note: I have seen this replay. I followed it, it still doesn't work.

I am using Windows 8.1 on a Lenovo ThinkPad. I have two graphics cards:

enter image description here

They both seem to operate fine (as far as I can tell, NVidia Control Panel works fine, and Intel's one too).

I have just installed newest NVidia drivers from their website. I have just installed newest Blender (2.76b) using msi installer.

I have tried running it explicitly through option to use NVidia graphics:

enter image description here

And I still can't select Cycles renderer:

enter image description here

And I can't select anything else than CPU for Domputing Device:

enter image description here

I don't get any trace in Blender's system console that would indicate any issues. NVidia's GPU activity tool seems to pick up on Blender using its GPU:

enter image description here

Interestingly if I start it like above, with NVidia option, I can select different subdiv algorithms:

enter image description here

However if I run it selecting Intel card I get no choice:

enter image description here

So it does seem to make a difference which one I choose to run Blender through.

How can I debug what's wrong?

$\endgroup$
  • $\begingroup$ Try running it as administrator..? $\endgroup$ – someonewithpc Feb 27 '16 at 23:16
1
$\begingroup$

Cycles render should be available independently of which compute device is chosen, if no compatible graphics card is present it still runs regularly with the CPU.

If the Cycles render engine is not showing up it's probably because it's addon is disabled. Try Enabling it under Blender User Preferences > Add-ons > Search for Cycles.

As for using the NVidia card, right above the computing device pull down menu there should be two buttons that say None and Cuda you have to enable Cuda before Blender is able to recognize your graphics card as a computing device, I think.

Edit: Upon closer inspection of your screenshot, the CUDA button is not visible, so Blender is considering no compute capabilities are present at the moment.

You mentioned a laptop with two cards. Many of these systems use a low power (Intel) graphics card for battery saving and the High powered one for graphics heavy applications. There is usually some sort of switching system and profile manager for this sort of setting. Try activating the High performance profile or making the NVidia card the active one before running Blender, so that CUDA capabilities are present when the application starts.

$\endgroup$
  • $\begingroup$ Thank you! I have spent ages thinking something terribly wonky happened to my Windows installation and yet it was so simple. After enabling plug-in I could select Cycles Renderer. And after restarting Blender I can now select CUDA and my NVidia card. $\endgroup$ – elmo Feb 27 '16 at 23:32
  • $\begingroup$ Welcome. Hope it helped $\endgroup$ – Duarte Farrajota Ramos Feb 27 '16 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.