1
$\begingroup$

Im wondering why when I go to solve the camera in a tracked scene it defaults to being set to having a focal length of 24. If I have the focal length above or below 24 before doing the solve it sets it back to 24, but I would like it to stay at the focal length I have set before the camera solve.

$\endgroup$
  • 2
    $\begingroup$ You can set the refine option to nothing. One very important thing to check is that you are using the correct sensor width. From the tracked information blender can calculate the right lens quite accurately, but it will match the real camera lens only if the sensor size corresponds with that of the camera where you shot the original footage. Ultimately what's important is that the angle of coverage of the lens is calculated correctly. A 24mm lens will give you a much different angle of coverage on a full frame camera than on a APS-c sensor or a MTF. $\endgroup$ – cegaton Feb 27 '16 at 17:31
  • $\begingroup$ Even if I have refine set to nothing I still run into the issue of the focal length being set to 24 regardless of what camera settings there may be before doing the camera solve. $\endgroup$ – CSSmitty Feb 27 '16 at 17:46
  • 1
    $\begingroup$ What camera did you use to shoot and what is the Camera sensor width that you are using? $\endgroup$ – cegaton Feb 27 '16 at 17:56
1
$\begingroup$

Motion tracking Solver does not automatically applies the settings of the Solved camera into your scene's camera unless you press Setup Tracking Scene (Movie Clip Editor Window, in the Solve Tab).

enter image description here

Blender's default camera has 24mm so I guess you are not using this feature. If not, you may apply the Camera Solver Constraint manually and then change the Camera properties too.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.