1
$\begingroup$

This question already has an answer here:

I already made and rigged a character. When I make keyframes in the dopesheet to time my animation, the graph editor does not show any of my keyframes, for any of my animated parts. Even when I go to check the drivers, the driver pane is completely blank, just an empty graph as well.

The weird part is, a couple of sessions ago, it was working completely fine, because I know I was able to edit drivers then. So what could possibly be happening here? I unfortunately cant share the blend file due to the fact that it belongs to the project group I work with, but I was hoping for some general pointers on how I can figure this out. Keep in mind my dope sheet and NLA editor works completely fine, it's just the graph editor.

Here is an image of what it currently looks like:

empty graph editor

and here is the corresponding dope sheet for the same animation: dope sheet with the keyframes showing

$\endgroup$

marked as duplicate by David Feb 27 '16 at 17:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ post an image that displays the bottom part of your graph editor window (the part where there is a ghost, a life saver and filters) $\endgroup$ – cegaton Feb 27 '16 at 16:51
  • $\begingroup$ i posted two images just now, do those fit what you are talking about? $\endgroup$ – user3670987 Feb 27 '16 at 16:55
  • $\begingroup$ ...oh my god... thank you for pointing out the bottom of the panel. apparently when i click ghost all my curves MAGICALLY appear. so many hours i have wasted at this issue. $\endgroup$ – user3670987 Feb 27 '16 at 16:57
1
$\begingroup$

If you have hidden objects or bones they won't show in the graph editor window unless you enable the switch to display them.

enter image description here

More info here: https://www.blender.org/manual/editors/graph_editor/introduction.html?highlight=graph%20editor

$\endgroup$
1
$\begingroup$

ok if fcurves are missing, click the little ghost icon at the bottom of the graph editor pane. apparently if that is off your curves wont show...why would they design it like that though?

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.