2
$\begingroup$

I'm using Blender for architecture modeling and I'm having a problem with the clear parent command.
I made a fence repeating a mesh on a bezier curve with the "make parent" and follow the father.
Now I want to work on this fence in edit mode but I can't really do it, I can just change the initial object and it changes all the elements along the perimeter. I tried the command "clear and keep transformation" but it doesn't work as I expected.

There is a way to turn my fence a mesh more editable?

I took 2 screenshots

before clear parent and keep transformation
clear parent and keep transformation

after clear and keep transformation the elements are gone.
after clear and keep transformation

$\endgroup$
  • $\begingroup$ Can you try bringing the parent's location back to 0,0,0 before clearing the child and comment back on if the results were any different please? $\endgroup$ – Rick Riggs Feb 27 '16 at 2:18
  • $\begingroup$ Do you mean this location ? No difference :/ $\endgroup$ – user22227 Feb 27 '16 at 11:28
  • $\begingroup$ Is any modifier involved in the creation of your object, that has not been applied? It's would be best if you can post a .blend file so we could take a look at the setting which may have created this behavior. $\endgroup$ – hawkenfox Feb 27 '16 at 15:05
  • $\begingroup$ I didn't use modifier :/ this is the model !! blender model $\endgroup$ – user22227 Feb 27 '16 at 20:26
  • $\begingroup$ I looked at the file, but I'm very curious as to one thing, how did you create the array? Regardless of that, I think that before you parent these to together, you need to apply at least scale, but scale and rotation would be wise for BOTH of the objects. I found this out by looking at the scale factor of both objects. They are both not 1.0, this is definitely causing problems, because if I highlight the Circle and apply the scale, your array gets scaled way out away from the center, and this is all before clearing the parent. $\endgroup$ – Rick Riggs Feb 28 '16 at 3:46
1
$\begingroup$

Shift + P and choose Clear and Keep Transformation.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.