1
$\begingroup$

FreeBSD installs blender without cycles; but I assume cycles is just an addon. Does anybody know the way to get it on there? Thanks.

$\endgroup$
2
$\begingroup$

The default configuration for blender on FreeBSD does not include cycles. If you install using pkg install graphics/blender then it will not be enabled.

To enable cycles you will need to compile blender yourself (assuming you have ports installed).

cd /usr/ports/graphics/blender
make config
(enable cycles in the menu)
make install clean

Note that building blender might require other ports that you may not have installed yet (like devel/llvm34 if you also enable CYCLESOSL), these can be installed using pkg install instead of compiling them yourself.

After the make config step you can use make build-depends-list to see what is needed to build and check if you have them installed.

Cycles was disabled by default as there is sometimes an assert from boost that causes the build to fail. I find this only happens when generating the man page which can be removed from the Makefile.

$\endgroup$
0
$\begingroup$

Blender 2.77a and earlier version build without problem but it doesn't run if Cycles engine is enabled which make not so much usable on FreeBSD.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.