3
$\begingroup$

When rendering (blender render, version 2.76) a fire animation, it leaves a dark field/area in the rendered picture. The size of the field seems to depend on the size of the domain around the animation.

Does anyone know how to remove this, as it kind of spoils the final result?

enter image description here

The blend.file can be downloaded via below link: http://www.mediafire.com/download/1kgzxbti2b7y0g1/World+ANI22.blend

$\endgroup$
  • 2
    $\begingroup$ could you delete all the elements we do not need and posted a simplified .blend file to reproduce the problem so someone may point you at the right direction. On the back of my mind it could be caused by various issues. $\endgroup$ – hawkenfox Feb 25 '16 at 10:36
  • $\begingroup$ What do you mean by deleting all elements? I will upload a blend file right away... $\endgroup$ – Oscar Feb 25 '16 at 10:41
  • $\begingroup$ Well sometimes the file is too big to attach or the person asking the question don't necessary want to share the whole file. So it's ok to just delete away all stuff you don't need and only leave those stuff that are causing the described issue. Sort of cutting down the file size and focus on the problem. $\endgroup$ – hawkenfox Feb 25 '16 at 13:07
  • 1
    $\begingroup$ Could you please add a better screenshot of the undesirable artifact? $\endgroup$ – PGmath Feb 25 '16 at 13:32
  • 1
    $\begingroup$ @RickRiggs, Again thanks for helping out! I tried suggestion 1 and 2, didn´t work. Don´t know how to do no. 3. I have uploaded the wrong screenshot, the right one is there now. But you are right, as a alternative solution I could change the camera angle, so the dark area perhaps no longer is shown. Anyway, I have come a bit further. I found out that the dark area moves when I change the position of the lamp. So it seems as if the smoke domain is casting a shadow? But I can´t find where to turn of this off? Any ideas? I know it´s really hard to help when you don´t have the blend file. $\endgroup$ – Oscar Feb 25 '16 at 17:43
1
$\begingroup$

enter image description here

You can uncheck "Receive" in the Shadow Section for the material of the earth.

Alternatively for the fire, you could uncheck the 'Cast' checkbox. Whatever works for your situation.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ That helped! I removed cast for the smoke domain and receive for the two spheres. Not dark areas anymore. Perfect. Thanks a lot for your help! $\endgroup$ – Oscar Feb 25 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.