1
$\begingroup$

This question has kind of been answered here, but when I try to set the frame rate to the rate listed on the video (30fps in this case) it is still off by a large margin (400 extra video frames out of 18000 sound 'frames'). I have also tried using the speed control to adjust, but it will only correct to one decimal place, which will make the video either noticeably longer or shorter than the sound. I would like to know if there is any way to improve the precision of the speed control feature, or (ideally) set a start and end frame rate, and have blender average the frames in between.

$\endgroup$
  • 2
    $\begingroup$ 400 extra video frames out of 18000.. if you look at the fps drop down in the render properties panel there is a 29.97 frame rate preset. Have you tried that? $\endgroup$ – batFINGER Feb 25 '16 at 10:11
  • 1
    $\begingroup$ So, it appears there are actually extra video frames relative to sound 'frames'. The audio is about 18000, and the video is 18400. The file says it was 30fps and when I recorded it, I specified 30fps, but it appears it recorded extra. I tried changing the fps to 31 (too slow) and 32 (too fast). If I try to change the fps to a custom fractional framerate, it automatically changes it to a whole number framerate (31.5 goes to 32). I tried using the speed changing option (shift+a, speed control), and it only goes to 1 decimal place which unfortunately also isn't precise enough. $\endgroup$ – A D Feb 25 '16 at 22:49
  • $\begingroup$ Related: blender.stackexchange.com/a/44060/2843 $\endgroup$ – Samoth Feb 26 '16 at 12:41
3
$\begingroup$

What @batFINGER says is true. If you have your blender anim set at 30fps, but your video is really playing at 29.97 fps, the sound track and video tracks will get imported at different lengths.

presumably because sound is imported as a single item with a timespan, and the video is imported as a range of frames, each being dropped in a frame slot. Someone else may know for sure.

You just need to play with the FPS until the two strips align.

In the first image I have imported a 6mb video at 24fps. The two strips show as different lengths.

wrong fps

In the second image, the strips line up. But I had to use a custom '15fps' because I have a cheap android phone.

right fps

Shouldn't be too much of a pain to sort through the dropdown options.

If you need a unique frame rate, you can select 'custom' from the Frame Rate dropdown. (it's the first item, and looks like a title.) Enter something close to actual frame rate. Then you can use the divider '/' field to adjust.

almost 31 fps almost 31 fps almost 32 fps

You can see in the images the resulting frame rates are: 31.01, 31.37, and 31.71 respectively.

$\endgroup$
  • $\begingroup$ So, the issue is that the video file has extra frames (it averages to somewhere between 31 and 32 fps). Unfortunately (and I don't know if this is an option that can be changed), blender will not let me enter in custom fractional framerates; it defaults to whole numbers, and so I can not properly line up the audio and sound. $\endgroup$ – A D Feb 25 '16 at 22:56
  • $\begingroup$ @AD I added more info to the answer showing how to adjust between 31 and 32 fps. $\endgroup$ – dval Feb 26 '16 at 0:57
  • $\begingroup$ That addition is perfect, thank you very much. $\endgroup$ – A D Feb 26 '16 at 4:18
0
$\begingroup$

I'm not sure if this answers your question but if you have premiere or a free equivalent you should be able to get the two together no problem. You just need to make sure that both your Premiere / Blender session are at the same audio sample rate (Audio is my skill set, Blender I'm learning so I hope I'm right here).

Most movies will put the audio in at 48kHz but most audio from CD's etc is 44.1kHz this will make the audio faster. Ideally convert your audio to 48kHz (you could use audacity to do that)

As I say I'm not sure if this is the problem but if your video is 3mins and your sound is 3mins it should match perfectly if it's not there's a sample rate issue I imagine. - I could be totally wrong of course :)

$\endgroup$
  • $\begingroup$ I was trying not to have to download additional software for this, but I may have to end up doing it. The major issue is that blender seems to import video frame by frame, so it gets all the frames (which is great), but runs the frames at the framerate set in blender. The sound is imported separately so that it is not stretched or shrunk. Unfortunately, this can lead to a difference between the video length and the sound length, and there does not seem to be an easy way to scale the video down to the length of the sound. $\endgroup$ – A D Feb 25 '16 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.