8
$\begingroup$

I've made a smoke+explosion simulation and everything works just fine in viewport. But I have two issues that you can check in the blendfile below:

The first one is that some of my smoke is not rendering at all. The next images have the same scale.

enter image description hereenter image description here

As you can see, there is a smoke plume missing in render. It's weird because they came from the same emitter object.

The second issue is that the smoke disappear when the simulation goes further as if the flow object was emitting no more. Again the images have the same scale and placement.

enter image description hereenter image description here

It looks that the problem is not in the material but in the density of the smoke. This is an image of the Density Factor output and the problem is there yet:

enter image description here

$\endgroup$
  • $\begingroup$ I looked at your blend, it's very strange... the only thing I can think of is that it has something to do with your material, but I'm not very experienced with groups and couldn't figure out how to find it. My suggestion is that you try an identical scene with the 'quick smoke' (in quick effects) preset material and see if it's any better, then you can edit that material to will (if it works). $\endgroup$ – Cubit Feb 19 '16 at 8:58
  • $\begingroup$ Good point, but it doesn't work either. But now we now that the problem is not in the material at all. The density factor (from Attribute Node) gives the same result, so the problem is in the Smoke Density. I'm gonna edit my question to add this. Thanks! $\endgroup$ – Antonio Buch Feb 19 '16 at 10:30
  • $\begingroup$ You're welcome O.o Can't say I know much about the smoke density though... Good luck :) $\endgroup$ – Cubit Feb 19 '16 at 20:59
  • $\begingroup$ The size of your smoke domain and distance from camera are quite large. Fine you may need that. I noticed when I scaled domain and adjusted camera to zoom in on smoke, the preview and render more closely. My test was for a domain approximately base 8 * 5 units. I used [group] smoke density set to 8. Part of that motivation was to decrease render time. Certainly a smaller domain provides more detail given other settings the same. I am wondering if smaller domain tend to look more like the preview. [group] smoke density to 15 produced thicker smoke everywhere but did not preserve detail. $\endgroup$ – atomicbezierslinger Feb 20 '16 at 2:00
7
$\begingroup$

This is because the max steps + step size is limiting the maximum distance volume rays are allowed to travel to a distance smaller than the total width of your domain.

Your domain is over 350 meters wide in the shortest axis. With the current settings in Render settings > Volume Sampling, the ray can only travel 1024 steps at .1 meters (BU) per step. In other words, the ray can only travel 1024*.1 = 102.4 meters before it must give up.

There are a couple ways to fix this.

Increase the max number of steps

This will keep everything as it is, but allow the rays to travel farther. It will likely increase rendertime however.

enter image description here

Increase the step size

This will make rays jump farther between steps and significantly speed up rendering, but may make the volume appear less detailed.

1024*.5 = 512 meters/BU, which is quite sufficient to traverse the whole of your domain. Note that details smaller than the step size may be "jumped over" by volume rays as they step along, essentially rendering the volume like those details were never there.

enter image description here

Use Equiangular sampling

Depending on your exact situation, you might find it's faster/less noisy to use Equiangular sampling for your volume. You'll have to experiment and see what works best in your scene.

enter image description here

$\endgroup$
  • $\begingroup$ I was about to report it as a bug! I found a workaround though: make another scene with the domain scaled down, reading the same Cache and the camera zoomed and shifted to have the new domain in the same place of the screen. $\endgroup$ – Antonio Buch Feb 23 '16 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.