I exported an svg 1.1 file from Adobe Illustrator CS6. I joined all the shapes by pressing Ctrl+J. I set the curve shape to 2D. Then I extruded using the right hand side panel:


So far so good. But when I try to apply even a slight bevel, all hell breaks loose:

Bevel hell

It does get less insane if I bring the bevel down by multiple factors of 10... But then I really don't have much of a bevel.

Am I doing something wrong? Am I using the wrong kind of object? Should I be doing this with meshes? Do my curves just need cleaning up?

  • $\begingroup$ Here you go! Thanks everyone for the help. I realize this question/problem might be a little naive, but I'm struggling to figure out Blender: Download the .blend file $\endgroup$ Feb 18, 2016 at 17:09
  • $\begingroup$ As mentioned below in my answer the problem with your curves lies in the font objects, particularly the "S" "B" and "C" characters, there are a lot of overlapping vertices there. Also one thing you might want to do is separate the top text "Université de Moncton" and the "Chimie & Biochimie" into their own separate objects, since the are comprised of smaller objects with narrower distances with finder details you may want to use a smaller bevel factor for them, as larger bevel factors often result in overlaping geometry. $\endgroup$ Feb 18, 2016 at 17:22

4 Answers 4


Most likely your curves need cleanup.


You mentioned joining all objects after import, make sure all segments are closed curves, not separate lose segments inside one bezier object.

I would advise checking for any loose vertices, and more importantly overlapping segments, which are the most likely to cause the artifacts similar to your screenshot. Besides that very tightly close vertices, very short segments, and mostly very sharp angles tend to cause problems with beveling.

Illustrator often adds filters and effects (like drop shadows, outlines, or contours) that when converted to SVG become loose curves overlapping the original shape that often cause issues. Make sure to disable or exclude them before exporting, or cleanup afterwards

In your case the most likely culprit is the the font objects. Check the text part of your logo, fonts are often sloppily designed or of low quality, or simply not prepared for 3D modeling and contain overlapping or very close together vertex which can cause problems.


To clean up the curves the best method I could think of consists of selecting one vertex belonging to a text character; make sure you select the right one as there are often several overlapping. Blender highlights the whole spline that vertex belongs to with a different color so make sure you are not selecting a duplicate by checking if the whole character is marked with a different color (as opposed to marking only the single vertex you select).

Then proceed to select all linked vertex by pressing Ctrl+L making it easy to hide them with H

You are then left only with the loose or duplicated vertex visible which can easily be discarded by deleting

enter image description here

Anyway here is the clean file, problems were as suspected the font objects

enter image description here

  • $\begingroup$ In AI the paths were all compound, but that information was lost during export/import so that afterwards I had an object for each closed spline. I joined each of these closed splines into a single object. The first thing I did was check for loose vertices by entering edit mode (pressing tab) and selecting all vertices (by pressing A). I didn't detect any loose vertices, but I can't be sure as I don't understand what causes the problem. Font is Futura... I forget where I got it but I think it was a good version of it (Adobe?). Text was converted to outlines in AI. Uploaded my .blend above. $\endgroup$ Feb 18, 2016 at 17:23
  • 2
    $\begingroup$ @GuillaumePelletier the SVG importer does not support all of the features form Illustrator, It's a lot easier to import into blender if your original file is simplified to basic closed paths with no effects. $\endgroup$
    – user1853
    Feb 18, 2016 at 19:50

This is the result of really messed up topology. This is to be expected when you're working with curves. Remember, curves are geometry also! The main difference between them and vertex based objects are how you interact with them.

There are two ways that you can get a clean enough mesh for beveling. You can clean up the original mesh, or you can remodel it. I personally would remodel it. This is usually a cleaner and more controlled way to do it because you're deciding where the geometry goes instead of letting Blender do it.

Cleaning up the original mesh

Start off by removing the bevel and extrude. We'll bring those back once the text is a nice clean mesh.

Then press AltC and select To Mesh. This will convert your text from a curve to a mesh.

Then Tab into edit mode. Now we'll start the actual cleaning. To start off, press W and select Remove Doubles. This will remove the doubled vertices which are extremely common in meshes like this.

Now comes the hard part, removing geometry. The most important thing is the outline, so start by removing all the interior faces. Press A then X and select only faces. This will get rid of all of the faces. But the edges will still be there, so carefully select some of the unnecessary edges (I like to box select them with B, and delete them (always use the edges option, using selecting vertices will delete remove the outline). Make sure to leave the outline intact.

Now that we've gotten rid of the interior edges, it's time to clean up the outline. Why?


Well, I think think I need to say anything...

There are a lot of edges that are somewhat like that. To take care of them, let's switch to vertex view mode using CtrlTab so that we can see them.

Start by selecting some of the virticies that are in streight parts of the lettering. Press G to move them. You're looking to see if they're dragging along any other edges. If they are, delete them. This time, use the Vertices option.

This get's rid of most of the harmful edges and virticies. Now it's time to get rid of the ones that just aren't necisary for the shape. These are vertices that are in straight parts of the mesh, and vertices that don't give any more important information to curves.

With these ones, select them individually, and delete using the option of Dissolve Vertices.

Just be sure that you don't remove too much it can be hard to go back. For me, I tend to remove every other vertex while making sure that what I'm removing doesn't effect everything else much.

Finally, carefully work on filling in everything. For this, just try to follow good guidelines of topology. Avoid triangles, but be okay with adding them if necessary. This part of it is hard to really explain because you basically just have to give it a try and see what works.

Modeling from scratch

This is probably my favorite method for doing things like this. You can see part of the reason above, the first method is a lot of work. I find for these kinds of things, I prefer starting from scratch because I can completely skip the cleaning part, and go straight to making an outline, and then filling it in.

To start off with this, bring in a background image of the logo/text, or import the logo/text and place it below the grid. Go into top view, add a plane, go into edit mode, and delete three of the verticies. From here, move one of the remaining vertex into place, and use CtrlLeft Mouse to extrude out an outline.

Then fill it in like we did in the first method.

Extruding and Beveling

To finish off those two methods, we need to extrude out the logo, and we need to bevel it. Do this by adding a solidify modifier and a bevel modifier and adjusting the settings from there.

  • $\begingroup$ This method also works well, and I am specially an adept of the "Modeling from scratch" option, converting to mesh however is a 'destructive' workflow and some information is lost, especially for curved segments. For this sort of thing I always prefer keeping the original object as a curve for as long as possible and solving the cleaning part directly from the curve object. $\endgroup$ Feb 18, 2016 at 23:44
  • 1
    $\begingroup$ @DuarteFarrajotaRamos That's true, It all just comes down to curves and meshes being two different formats and workflows. I do think that this method shines more when you're working with Blender's text objects though. You still might be able to convert to a curve and fix the issues there. But I never realized that the issues could actually be traced back to the geometry of the curve. I always thought that the issues came with the conversion. You learn something new every day :) $\endgroup$ Feb 18, 2016 at 23:53

Because .svg imports into Blender as a curve object, you need to convert it to a mesh with Alt+C>mesh from curve/meta/surf/text. Then you can modify the object however you wish.

  • 2
    $\begingroup$ Curves can have advantages over mesh objects for certain situations, and provide certain benefits for logo design. I would advice against converting to mesh, in this case the user would most likely end up with an awful topology to deal with and not necessarily solve the underlying problems that are causing the artifacts $\endgroup$ Feb 18, 2016 at 16:33
  • 1
    $\begingroup$ I did try working with it as a mesh object, but I was having issues with goofy geometry, as Duarte Farrajota Ramos predicted. I was also having an issue with the extrude step itself when I tried using the mesh (some of the shapes wouldn't properly extrude, it just looked like I was duplicating the mesh and translating it on the Z axis). $\endgroup$ Feb 18, 2016 at 17:12
  • $\begingroup$ Check the new answer bellow, I posted the clean file for you $\endgroup$ Feb 18, 2016 at 17:38
  • 2
    $\begingroup$ @DuarteFarrajotaRamos you shouldn't post it for me, rather than for everyone willing to learn the instructions on the procedure. Provide some steps as for what you did instead of just image and file. $\endgroup$
    – Mr Zak
    Feb 18, 2016 at 18:03

I found that straight-line corners were problematic, but curves where bezier handles create curvy curves were not.

A relatively quick fix is to select vertices and then, while in Edit Mode go to Control Points > Set Handles Type > Vector.

Seems to clean thing up quickly.

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .