0
$\begingroup$

I am making a checker board type piece as pictured. I used the loop cut and slide to break up the rectangle into smaller rectangles and then extruded them upwards. It is now showing as a non-manifold problem and I can't figure out how to fix it. Thanksenter image description here

$\endgroup$
1
$\begingroup$

There are non-manifold regions in your mesh. You should extrude faces upward in another way and it will work.

Why non-manifold

The reason for non-manifold in this case are areas with no thickness. For example, this connection:

example of non-manifold connection

The edge, which consists from selected vertice and bottom one, shares 4 faces and perfectly fits reason for being non-manifold.

You can notice that non-manifold is selected only in areas where these connections are present:

non-manifold area

Note area in top middle - there isn't any face extruded further, hence there isn't any zero-thickness edge.

How to repair

Delete those faces and fill holes in mesh in order to make this surface flat and solid again, select the pattern how you'd like to extrude and use Extrude Individual operator with Alt+E.

extruding individual

After individual extrusion faces aren't connected to each other and do not have any shared edges.

What about removing doubles

If you remove doubles at this point, faces will have edge shared again (because after extrusion vertices are located in the same places), hence will become non-manifold again.
You can skip this step because doubles won't be detected as non-manifold, still lack of possibility to remove them may be undesired. With extruded faces still selected, set Pivot Point to Individual Origins and scale them a bit inwards:

faces scaled in do not share vertices

| improve this answer | |
$\endgroup$
  • $\begingroup$ @LarryGuthrie small note - there's another way to avoid extrusion to become non-manifold again after removing doubles. On the first step of the repairing process with faces-to-be-extruded selected inset them (press I) just a bit. Then extrude as desired; no scaling needed after that because extrusion already won't have any shared vertices. $\endgroup$ – Mr Zak Feb 20 '16 at 23:28
1
$\begingroup$

The Face on the side of your mesh shows a N-Gon (Face with more than 4 Vertices). You should make sure that you only use quads (and tris if necessary) to get a good edgeflow to work with.

See if you can fix that by Hand (K is shortcut for knifetool, so you can insert edges manually) and when you're done you can also use Blenders Cleanup Function. Go to Edit mode, select all faces and go to Mesh (in the 3D viewport header) -> Cleanup. There you'll find a few options to cleanup other nonmanifold geometry like lose edges or double faces. It has Tooltips if you hover your mouse over it.

Hope this helps you, Happy Modeling :)

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.