0
$\begingroup$

I have a model with no complex shading, only Lambert diffuse and a texture. I have these weird black spots and buggy lighting that appears when exported to a game engine too. How do I fix it? https://drive.google.com/file/d/0BzBoGW_cEeBcVHhqZDU1V3RyTFk/view?usp=sharing enter image description here

$\endgroup$
  • 2
    $\begingroup$ Those are normals issues try fixing it using Ctrl + N $\endgroup$ – hawkenfox Feb 17 '16 at 19:37
  • 1
    $\begingroup$ If recalculating the normals doesn't fix it, is it possible you could upload the .blend? $\endgroup$ – gandalf3 Feb 17 '16 at 21:30
  • $\begingroup$ Ctrl + N just messes up the normals. It doesn't seem to work with backface culling. It also doesn't fix the shading. $\endgroup$ – glor Feb 18 '16 at 17:50
1
$\begingroup$

The main problem which causes this unexpected result is normals splitted in a wrong way.

  1. In Edit mode with all selected access Specials menu with W and choose Remove Doubles.
  2. With all still selected press Ctrl+N to recalculate normals.
  3. Then in order to get rid of ugly artifacts caused by smooth shading normals should be splitted (see How to smooth shade an object while retaining hard edges?). In Properties Editor > Object data tab in Normals rollout you can see that Autosmooth option is turned on but angle setting is greyed out. See What does it mean when my Angle setting under Auto Smooth greyed out ?.

    In the same tab open Geometry Data rollout; button Clear Custom Split Normals Data is active, so data is present.

    Custom split normals data location

    You can use 2 ways: clear custom split normals and set up either Autosmooth angle or Edge Split modifier, or leave custom split normals as they are (e.g. if they should be preserved) and uncheck Autosmooth option.


See also:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.