2
$\begingroup$

For some reason, I opened blender this morning and created a keyframe via moving the camera higher (z axis). However, when I play the animation, nothing changes from the keyframe before that one to that one. It was working perfectly earlier yesterday. How can I fix this? Thanks.

EDIT: Here's the .blend file:

$\endgroup$
  • $\begingroup$ Please post your .blend file. There are a lot of times when I say, "This is simple, why isn't it working?" and it turns out to be my error 98% of the time. From what you posted it's impossible to tell what is wrong, because by all means, that should work. $\endgroup$ – Blazer003 Feb 16 '16 at 19:31
  • $\begingroup$ Check whether you keyframed location of the camera in the first keyframe before creating the last one. Other than that this should work, so to guess your particular problem .blend file should be uploaded. $\endgroup$ – Mr Zak Feb 16 '16 at 19:59
  • $\begingroup$ I uploaded the .blend. $\endgroup$ – kzhao14 Feb 16 '16 at 23:24
1
$\begingroup$

You have converted key frames to an Action Strip (AS):

NLA Blender documentation

Disclaimer: I'm not so versed in the AS.

EDIT for clarification : From the doc:

The NLA editor can manipulate and repurpose actions, without the tedium of keyframe handling. Its often used to make broad, significant changes to a scene’s animation, with relative ease.

You convert key frames to Actions for easy reuse. Instead of key framing again or copy and paste keys (for example) of a running animation that need to repeat a couple of times, you repeat the cicle N times using the properies of the Action. Also you can Link Duplicate (Alt+D) an Action, this give you the ability to modify the original Action and all the successive Actions will be modified as well.

end EDIT

It means that all the key frames for the camera are now one Action Script, if you want to modify or add new keys you need to edit the Action Strip be selecting the AS and press TAB, now you can add a new key frame or delete them too.

enter image description here

I remember that the AS will override any key that is not in an action script in Tweak Mode. If you want to add a new key but not in the same AS, your new key need to be converted to an AS in order to override the last AS. Or look at the properies to define if an AS last key is permanent.

enter image description here

$\endgroup$
  • $\begingroup$ Is green, tried adding by moving camera, keyframe added, camera still doesn't move. $\endgroup$ – kzhao14 Feb 21 '16 at 22:57
  • $\begingroup$ It is the solution. I just tried it with your blender file: Added some more camera movement, clicked on the camera strip, pushed tab, the bar is now longer (till last keyframe) and is showing my added animation. Thanks for the solution, need to keep that in mind. Could you explan what's it all about that action strip? (slightly new to blender) $\endgroup$ – tommygun Aug 19 '16 at 14:21
0
$\begingroup$

Have you tried hitting the "I" button and clicking on "location" to set the first keyframe, then moving the camera upwards on the "Z" axis and once you positioned your camera Hit "I" again and click on "location" again? See if that helps.

$\endgroup$
  • $\begingroup$ Nope, doesn't work. $\endgroup$ – kzhao14 Feb 16 '16 at 23:25
0
$\begingroup$

The file you uploaded works for me here.

On opening the file the current frame is 800 where there is no more animation, so it stays stationary for a while until it loops back to the start or I manually go back to the start.

$\endgroup$
  • $\begingroup$ I added a frame at 800 by moving it up, but the frame doesn't have any upwards movement. $\endgroup$ – kzhao14 Feb 17 '16 at 16:37
  • $\begingroup$ Either you didn't add the keyframe or you didn't save it? $\endgroup$ – sambler Feb 17 '16 at 16:47
  • $\begingroup$ I added the keyframe, and I saved it. I put the green line at 800 (I think... the last keyframe) with the camera selected and moved it up with the blue arrow in 3D mode, and it added a yellow keyframe. When I played it, however, it didn't change from the previous keyframe. $\endgroup$ – kzhao14 Feb 17 '16 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.