4
$\begingroup$

I've seen a few other posts in various places about this problem. But having tried all the ones I've found I'm not sure what else to do.

My problem is that Blender renders my video out of sync with the audio. But it happens somewhat randomly. It's really annoying to find that every other video I render is very out of sync.

It's very simple footage too. Just footage of a game from my PC. Nothing complicated.

Now I'm sure I'm importing at the correct frame rate, it's at the correct resolution, and my frame range is right.

I've tried using all of the different timecode options, and not using it at all. Nothing seems to help. But I'm still new to using Blender as a video editor so I must be missing something. I also don't really understand what the different time code options are doing.

I didn't realize I couldn't edit my comments. I tried again with OBS and it still just records a black screen no matter what I do.

I should mention that I use Bandicam to record, with the "YouTube Preset". Which uses the Xvid codec.

@gdquest The addons you suggested seem to have solved this problem perfectly. As well as making editing a breeze. Thank you!

$\endgroup$
  • $\begingroup$ Try recording your footage to a file with Open Broadcaster Software and see if this helps. $\endgroup$ – Samoth Feb 15 '16 at 20:59
  • $\begingroup$ I'll try to use OBS again. I was having issues with it only recording a black screen a while back. If this works could the codec I'm recording with be the issue? $\endgroup$ – Code-E Feb 16 '16 at 2:20
  • $\begingroup$ related: blender.stackexchange.com/questions/31471/… $\endgroup$ – cegaton Feb 16 '16 at 4:18
4
$\begingroup$

I edit videos almost daily with Blender, but I never faced your issue.

I highly recommend giving Blender Velvets a try. The Velvet Revolver add-on allows you to transcode all of your footage to an editing-friendly video format, using FFMPEG. It also makes editing in Blender much more efficient, but that's another story! I recommend that you use the MJPEG format with Revolver, prores is way too heavy.

Revolver screenshot

Most video editing software out there only support a limited set of codecs for technical reasons, and you can have issues editing with videos that use the h264 codec. The lovely compression it provides comes at a cost: your video's frames are not available individually in the movie file, making it hard to decode, hard to split frames... so your issue is most likely due to that.

I hope it'll help, and if it doesn't, could you upload a blender file with a sample of the incriminated footage?

Kind regards, Nathan.

$\endgroup$
  • $\begingroup$ Thanks, I've added it to Blender. It's a bit late to start converting now, my files are pretty long. I'll get the results tomorrow. But I had a quick question. I read that long intervals between keyframes could be one culprit for this kind of issue. Would making a keyframe every frame help in the future? $\endgroup$ – Code-E Feb 18 '16 at 4:11
  • $\begingroup$ I don't think so. I use automatic keyframes for recording in both OBS and action!, and it works well. $\endgroup$ – gdquest Feb 24 '16 at 10:34
0
$\begingroup$

The VSE can have a hard time to get all the frames out in time for you to see, when that happens, what helps is to set the Sync Mode to Frame dropping or try the other modes according to your preferences. (Not sure if you already tried that when referring to "time code options".) Also under Playback you can activate Audio Scrubbing and/or AV-sync.

If you moved things around you might have to refresh the sequencer by hitting the Refresh Sequencer button to get things in sync again.

$\endgroup$
  • $\begingroup$ What you describe basically describes Playback sync problems, he asked about rendering sync problems... the Playback sync problems have been asked many times here before and are already addressed with answers. $\endgroup$ – Samoth Feb 15 '16 at 9:49
  • $\begingroup$ Right - missed the 'render' bit. :( $\endgroup$ – squarespiral Feb 15 '16 at 9:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.