9
$\begingroup$

This question already has an answer here:

I'm getting this error often, and I'm fairly new to blender and I'm not sure if this is the same thing as the Auto-run disabled issue, but I can't finish my project with this error in the way.

It says:

ERROR: Python auto-execution disabled.

error message

How can I fix this problem?

$\endgroup$

marked as duplicate by cegaton, gandalf3 Feb 14 '16 at 8:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

16
$\begingroup$

This might solve it, check here: https://www.blender.org/manual/advanced/scripting/python/security.html (Updated: https://www.blender.org/manual/advanced/scripting/security.html 10.23.16)

Relevant text as follows:

Setting Defaults

In the File tab of the User Preferences, there is the toggle Auto Run Python Scripts.

This means the Trusted Source option in the File Browser will be enabled by default, and scripts can run when blend-files are loaded without using the File Browser.

Once enabled you have the option to exclude certain directories, a typical configuration would be to trust all paths except for the download directory.

Auto Execution: Auto Run Python Scripts

$\endgroup$
  • 2
    $\begingroup$ Please try to include some more information. Link-only answers have the problem that if the link disappears your answer will make no sense (and even the blender manual has changed links in the past). $\endgroup$ – cegaton Feb 14 '16 at 6:25
  • $\begingroup$ I looked for around bit and the default setting option did the trick. I was using it in the graph editor. Thanks. $\endgroup$ – Akidus Feb 14 '16 at 6:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.