2
$\begingroup$

I am rendering a scene, and the plane in the scene is being clipped for no apparent reason. The near and far clip of the camera seems ok, but I extended it to 300 from 100, just in case, and no dice.

The following two images shows how it looks in blender, and the render result:

Blender workspace

enter image description here

enter link description here

3:

EDIT: Links to blend file added https://dl.dropboxusercontent.com/u/44179449/jeemoneygrungebrickangled.blend

https://dl.dropboxusercontent.com/u/44179449/jeemoneygrungebrickangled.blend1

EDIT 2:

I moved the camera back away from the plane, and this is WEIRD! Why is it not a rectangular plane? (Note: I moved the JeeMoney text over, so that didn't automatically change position because of the new camera distance)

enter image description here

EDIT 3: After 2 hours of fiddling around, I found out that I had a subsurf & displacement modifer that was messing everything up. I fixed it. Thanks all!

$\endgroup$
  • 5
    $\begingroup$ sub-surf modifier? $\endgroup$ – VRM Feb 14 '16 at 1:03
  • $\begingroup$ Please post your blend file so we can take a look at it more closely. $\endgroup$ – Todd McIntosh Feb 14 '16 at 4:39
  • $\begingroup$ I added the blend files via dropbox. $\endgroup$ – Jeeman Feb 15 '16 at 7:55
  • $\begingroup$ I mean, I put the links above in the original post. $\endgroup$ – Jeeman Feb 15 '16 at 8:08
3
$\begingroup$

This is because Clipping Distance settings exist in two places.

One set for the viewport (in your Properties Panel):

Viewport clip settings

...and another for the Camera / rendering:

Camera clip settings

Edit:

However...

Now that you've posted your .blend and I've had a chance to examine it, I can say your issue has nothing to do with clipping distance.

You have a SubSurf Modifier on your plane that is curving it.

SubSurf on Plane

It was set only to be visible in renders, not in the viewport.

Edit again:

I just saw your comment that you fixed it, so never mind. One last thing I'll mention - you can leave the SubSurf Modifier on, but switch it to Simple instead of Catmull-Clark, and this will give you the fine geometry for the Displace Modifier that follows, without rounding your plane.

$\endgroup$
  • $\begingroup$ Both nears are set to .1 which should be enough. I changed the end to be set to 2000 in the former, and 500 in the latter. Still get the same behavior. $\endgroup$ – Jeeman Feb 15 '16 at 8:07
  • $\begingroup$ Depending on the units you're using, the difference between the camera at 100 clip and 500 clip could be insignificant. Set the camera end clip to 10000. $\endgroup$ – OroNZ Feb 15 '16 at 11:53
  • $\begingroup$ Mentalist, thank you for looking into it! I appreciate your time! That was the solution! $\endgroup$ – Jeeman Feb 16 '16 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.