0
$\begingroup$

I have a camel mesh, both mirror and subdivision surface modifier applied, with armature on it and I wanted to give it some hair. I added a hair particle system with interpolated children and made a density group, but I have got some bald spots in some areas. I am sure, that I am using correct vertex group to control density, I tried to make some changes in the emission panel in the advanced particle settings. The only way to solve this I found was to make same number of hairs per face, as is the number of faces, but since I have over 12 000 of faces, this isn't quite ideal. here is picture of how it looks:enter image description here here are the problematic parts of my model: (so far I know about tail and legs. It isn't whole model, just the parts.)

$\endgroup$
  • $\begingroup$ I think we need more info. The easy way is to share the .blend file. If you are not OK with sharing your model give us only the back legs -in case that the error is still there wen you cut them out. $\endgroup$ – Antonio Buch Feb 13 '16 at 10:41
  • $\begingroup$ where can I share my model? $\endgroup$ – aky-her Feb 13 '16 at 11:32
  • 2
    $\begingroup$ here $\endgroup$ – Photon Feb 13 '16 at 11:51
  • $\begingroup$ I was about to suggest PasteAll, I didn't know about a site made for uploading blend files for Blender Stack Exchange. Cool! $\endgroup$ – Antonio Buch Feb 13 '16 at 12:14
  • $\begingroup$ OK, here is the file $\endgroup$ – aky-her Feb 13 '16 at 16:34
1
$\begingroup$

For some reason that I cannot find, some of the interpolated child hair strands are growing inwards -no bald areas actually. You can see little dots in those areas which are the root of that bad children that are growing inside the mesh. The interpolation is bad though the face normals are fine and I couldn't find any other cause for this.

So, as the problem is the interpolation between parents, the solution is adding more parents manually.

Go to the Particle Edit mode, then choose the Add tool and add a parent wherever there is a bald spot. Then, the Children will rearrange around the new parent and will face towards the face normal as the parent.

enter image description here

You can se above that I fixed the right leg.

Note that doing this means have more parents and, eventually, will create more children too. You might want to change the number of children.

$\endgroup$
  • $\begingroup$ ![enter image description here](i.stack.imgur.com/ZQyZn.jpg)I was searching for this answer, but it does not seem clear what the answer means by "use the Add tool and add a parent wherever there is a bald spot". What is the Add tool? Does this mean to create a particle system for each bald face? (Strangely, I too am creating a camel!) $\endgroup$ – NCBlender Aug 27 '16 at 19:41
  • $\begingroup$ When you are in Particle Edit mode, you'll see a bunch of tools in the viewport's Tool shelf (T in the Viewport). The usual one is the Comb tool, but you'll find some more including the Add tool. $\endgroup$ – Antonio Buch Sep 21 '16 at 8:49
0
$\begingroup$

I recently encountered a similar problem myself. The particle distribution wasn't remotely even on my model and showed up all patchy. I also had problems with the particles changing 'on their own' when I switched from particle edit mode to object mode. On my travels I found this question, and the last answer pointed out that having modifiers on the model with different values for "view" and "render" can cause all kinds of issues with particle fur. I found setting my modifiers to show the same value in render and viewport instantly solved the problems I had with patchiness and with particle edit. I also found when experimenting with the mesh that sometimes just adding extra edge loops (particularly on the legs of the model, where the faces are frequently longer than the rest of the body) can help the particle system have an easier time distributing the hair evenly.

$\endgroup$
  • $\begingroup$ I tried to remove all modifiers, add extra edgeloops and also set the view and render values of everything i could find to the same value, but it didn't work. $\endgroup$ – aky-her Feb 14 '17 at 20:19
0
$\begingroup$

I had the same issue. In my case, I fixed it by ensuring these thing in this order:

  • Scale and rotation was applied on the mesh object
  • Transforms were applied
  • Normals were correct (Ctrl+N in Edit Mode with everything selected).

Then, if there was any bald spot, using the Particle Edit mode, I could "paint" more hair over the bald areas without problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.