28
$\begingroup$

Any idea of why my viewport preview of the simulation stops at 250 frames? (as you can see on the orange line on the timeline)

Am I maybe missing any kind of configuration?..

It's a rigid body simulation.. e.thing works fine but the preview freezes at 250 frames.... No keyframes on the simulation, only on the colliding object that has an infinite loop rotation.....

the orange preview line

Is it maybe because of motion paths setting? It is set on 300......

enter image description here


Update:

Problem solved! I missed this tab of configurations!!

enter image description here

$\endgroup$
0

4 Answers 4

15
$\begingroup$

Did you bake the physics when your animation length was at 250?

If so, free all bakes, change a value, then bake again (and make sure you have the dynamic length of the bake set long enough). [You must change a value to reset Blender's built-in caching, and make sure it starts from scratch. You may then change it back.]

Here is an example of setting the length for a cloth simulation.

enter image description here

$\endgroup$
7
  • $\begingroup$ I missed the rigid body cache tab on the scene panel!! Problem solved!! THANKS :D $\endgroup$ Feb 13, 2016 at 2:53
  • 3
    $\begingroup$ Yeah, I think the cache limit is for the sequencer only. Also, I kind of doubt that if it was what was stopping it that it would be stopping at frame 250. That would have to be a huge coincidence since that's the default end frame for everything. $\endgroup$ Feb 13, 2016 at 3:49
  • 1
    $\begingroup$ Off Topic: I think the cache limit should automatically coincide with the timeline duration. But, still be adjustable. $\endgroup$
    – Dontwalk
    Feb 13, 2016 at 4:12
  • 1
    $\begingroup$ Yeah, I think I saw an addon for that.... But many would get annoyed if it were in the main branch, cause if they change the length of the animation, their custom value would be lost. I may try to make an addon like that though, if there isn't one, where there is a button to lock all those values to the frame range, cause I've been medeling with trying my own addons recently. I'll write it down as something to look into. $\endgroup$ Feb 13, 2016 at 16:05
  • 1
    $\begingroup$ The cache limit for rigid objects or physics simulation has nothing to do with the Cache for the sequencer/Clip editor on the preferences. $\endgroup$
    – user1853
    Jan 13, 2017 at 14:11
2
$\begingroup$

when you working with an rigidbody simulation, you can adjust same setting over to the scene tab(such as duration, gravity scale, speed, fps).enter image description here

$\endgroup$
2
$\begingroup$

I faced a similar problem with hair particles, and I've figured out how to solve finally. There was no way to delete cache or recalculate for me, I've tried any solution in various blogs. The trick for me was to set the start/end frames and then duplicate particle system and delete old, this operation forced blender to throw away any issue connected to the "bugged" hair particles. Hope you find this useful if any other tip doesn't work.

$\endgroup$
0
$\begingroup$

I got a far more satisfactory ending for my rigid body simulation (With Blender 3D 2.92 in March, 2021) when I went to Scene Properties/Cache and changed the End number to 410. Underneath it is stated 350 frames in memory (4.8MiB) that changed to 367 frames in memory (5.1 MiB).The icon for Scene Properties has a white cone, black sphere and a white dot.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.