8
$\begingroup$

I am working in the compositor with a lot of textures and distort nodes, which makes it very slow (easily 20-30 seconds to composite.) Every time I make a change, it re-composites. This is fine when just moving nodes around, but there are other operations that you can't do until it finishes. For example, Undo. If I want to undo 3 or 4 times, I have to wait for it to finish compositing every time. Likewise if I want to work in the texture nodes part of the nodeviewer, I am often waiting on the compositor to get node previews.

Is there a way to tell it not to automatically composite? I want to make a bunch of changes and be able to see the part I'm working on in a viewer node, but not run the entire stack. I understand that I can mute all the other nodes I'm not using, but that is troublesome and doesn't help with the Undo issue or problems when working in texture nodes. I can be stuck waiting on the compositor even when doing Undos on meshes or materials, which are entirely unrelated.

$\endgroup$
5
  • $\begingroup$ You can temporarily disable Backdrop button in the bottom of the Node Editor. This won't be counted as action so it isn't affected by undo history. $\endgroup$
    – Mr Zak
    Commented Feb 11, 2016 at 22:45
  • $\begingroup$ related: blender.stackexchange.com/questions/40369/… $\endgroup$
    – user1853
    Commented Feb 12, 2016 at 0:40
  • $\begingroup$ Neither Backdrop nor Autorender are enabled. To clarify, the problem comes when I've done a render, and then want to edit the compositor nodes, or go back to make changes to the model before the next render. $\endgroup$
    – Ascalon
    Commented Feb 12, 2016 at 2:14
  • $\begingroup$ When you have multiple groups of noise textures and multiple displace and blur nodes, it'll get slow. Closing the compositor window does take care of the problems when working in other modes. $\endgroup$
    – Ascalon
    Commented Feb 12, 2016 at 19:05
  • 1
    $\begingroup$ You can temporarily disconnect the Composite node, make the changes, and put it back. However, this doesn't work for the top end of an undo history stack, since the first undo will be connecting the node back. $\endgroup$ Commented Jul 22, 2016 at 2:42

1 Answer 1

9
$\begingroup$

I find that pressing the "use nodes" works for this task (next to backdrop tickbox). When you want Blender to composite again just re-enable it.

screenshot:

use nodes

$\endgroup$
1
  • $\begingroup$ nice trick. If you add a screenshot indicating the checkbox then the answer becomes complete. $\endgroup$
    – aliasguru
    Commented Sep 30, 2016 at 11:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .