This question has been asked before but all the answers I found have not applied to me. My armature has the logic bricks "keyboard sensor> and > Action" with my animation selected and frames specified. No objects in the scene have any modifiers other than my characters armature modifier. I tried parenting my object to the armature and removing the armature modifier, but that didn't work. Always sensors do not work either. Also, the animations work perfectly when played before the game is started.

Here's my blend https://www.dropbox.com/s/l3bisldlm1prx5l/kirby2k162.blend?dl=0

  • $\begingroup$ Kirby's mesh is not parented to the armature, do ctrl+P with both objects selected. see this related post:blender.stackexchange.com/questions/19656/… $\endgroup$
    – ruckus
    Feb 12, 2016 at 15:39
  • $\begingroup$ That did it thank you! I thought I had tried that before but I think I was doing an armature type parent, as opposed to a object parent, which is what worked. $\endgroup$
    – PapaFranku
    Feb 13, 2016 at 6:59


You must log in to answer this question.

Browse other questions tagged .