2
$\begingroup$

First you make a group from 3 items
When you select the "entire group"
When duplicating The following happens:

enter image description here

The items are not in a new Group.
I can understand that when you copy items inside a group.
That you want them to stay inside.
But would be good if you select entire group specifically.
That it copies it in its entirety.

Or am i missing something?

If not.

Is there a quicker way then instead of having to remove them first.
Then adding to a separate new one?
Gets very tedious after a while :P

$\endgroup$
  • 1
    $\begingroup$ It isn't clear enough what's the problem. If you want to organize a scene using groups, create one from some objects and add it as a group instance (Shift+A > Group Instance), not by duplicating. To select all the elements of the group use Shift+G > Group. $\endgroup$ – Mr Zak Feb 10 '16 at 22:19
  • 1
    $\begingroup$ I tried to be as clear as possible smile. When duplicating an entire group. It does not duplicate the group. it only duplicates the items and keeps them inside the same group. $\endgroup$ – ChoCho Feb 13 '16 at 17:03
  • 1
    $\begingroup$ I really don't know how i can be more clear :P Duplicate a group just like in photoshop for example, where it makes a Group (2) with all its contents inside. $\endgroup$ – ChoCho Feb 17 '16 at 13:49
  • $\begingroup$ In Blender you don't duplicate group to make objects from group to be repeated across the scene. You add instance of a group by pressing Shift+A > "Name of group". If you want to create completely another group Group2 which could be edited independetly from Group1 then you create another group either by Ctrl+G or in Properties Editor > Object tab. $\endgroup$ – Mr Zak Feb 17 '16 at 14:29
0
$\begingroup$

After using Shift+D to duplicate the group it will indeed create those ugly copies. No, go to Objects > Group > Remove From All Groups. Then just regroup them.

All the objects of interest should've stayed selected.

$\endgroup$
0
$\begingroup$

Yes, when you select a group and then you try to hit Ctrl + D. It duplicates all the object but puts it inside the same Group.

To fix this try to copy/past e(Ctrl C, Ctrl V) after selecting the group. It will then duplicate the group

enter image description here

This worked for me. Hope it helps.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.