0
$\begingroup$

I have some meshes that are parts of hallways with different crossings but all walls have no thickness. For purposes of rendering it in a game I program they need thick walls (for avoiding artifacts with shadow mapping).

How can I achieve this thickness with Blender? My three conditions are

  1. No self intersections: I know about the solidify-modifier but the angles of my mesh make it so, that the new thickness intersects with itself which is not ideal (z-fighting).

  2. UV-coordinates of all pre-existing vertices have to stay the same. We have a cool looking texture and the texture-mapping has to stay the same.

  3. Stay tileable: The meshes get positioned next to each other in order to form a maze. This has to be possible with the thick meshes.

The outward appearance of the mesh is not important since they are only seen from the inside. Additional I should be able to do this within a day for round about 10 meshes.

$\endgroup$
  • $\begingroup$ Is this question answered, or is more information needed? Please notify if you need more help. $\endgroup$ – Uncle Snail Feb 13 '16 at 2:35
  • $\begingroup$ Had no time to really try it out. On a small glace it seemed to work. I will accept the answer $\endgroup$ – Dragonseel Feb 13 '16 at 9:11
  • $\begingroup$ Okay, thanks. Make sure to tell me if you need more help! :) $\endgroup$ – Uncle Snail Feb 13 '16 at 15:52
1
$\begingroup$

I don't think you can use a modifier in this case. You will probably have to do it manually.

  • Go into edit mode tab
  • select all a
  • extrude e
  • scale shift+y, (which will only scale on x and z.)

Now, if there are faces which are on top of each other (in the same place), you can try any of these options;

  1. s, then y to scale along y.
  2. Change pivot point to individual origins, then scale on y.
  3. Simply adjust it manually.

It's hard to say what you should do, because I haven't seen the mesh, but this should help. Keep in mind, that I am assuming facing down your tunnel is the y axis. When scaling, you want to exclude the axis you are looking down, so that it only gets wider, not longer.

I hope this helped, please comment with any questions.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.