Blender will render 1 frame, then pause for two minutes, then do the same thing again with the next. Is there anyway to fix this? I posted a question thinking blender just stopped after frame one, but the program pauses for two minutes in between two frames.

enter image description here

  • $\begingroup$ What message do you get at the top of the screen? Are you using particles or Physics simulations? Can you describe the kind of scene you are dealing with? Lots of vertices? Big textures? Cycles or Internal? Can you post your performance settings? How much RAM? CPU, GPU? $\endgroup$
    – user1853
    Feb 6, 2016 at 2:02
  • $\begingroup$ @cegaton I don't know what you mean when you say message at the top but, I have 4 particles systems, no big textures, I have 353,646 vertices, I am using cycles, I have 16 gb 1600 MHz ram, and I can only use CPU. Also when I render it only goes up 1 gb. I don't know if its using too little ram or what's going on $\endgroup$ Feb 6, 2016 at 2:10
  • $\begingroup$ @cegaton Okay so what should I do? $\endgroup$ Feb 6, 2016 at 2:23
  • $\begingroup$ see: blender.stackexchange.com/questions/27538/… $\endgroup$
    – user1853
    Feb 6, 2016 at 2:49
  • $\begingroup$ @cegaton Okay so when I try to bake anything, it says that the program is not responding. Is there anything else I can do? $\endgroup$ Feb 6, 2016 at 21:52

1 Answer 1


Blender is not pausing between rendered frames: its generating the curent frame, and sometimes it can take a long time to calculate all the information needed to start rendering.

3D rendering can be one of the most compute-intensive operations you can throw at a computer. With very little effort you can create scenes that will push your system to its limits.

You are probably taxing your system with a scene that has:

  • Lots of particles
  • Physics Simulations
  • Lots of vertices (either from complex/detailed objects, or from vertices created by modifiers, like subsurf modifier or arrays).
  • Volumetrics (volume scattering and/or volume absortion).
  • All or some of the above, and maybe even other layers of complexity...

You have the option to:

  • Wait
  • Optimize your scene
  • Split the rendering load on different computers (like a Render Farm)

You might be able to find what process is taking so long by checking the top of the UV/Image editor window while rendering:

enter image description here

Things you can do to make the scene more friendly and renderable within your lifetime?

  • Simplify the geometry: decimate or re-topologize.
  • Use smaller textures. Textures shouldn't be any larger than the size they are going to be on the final render.
  • Bake textures and lighting if possible.
  • Cache simulations and particles to disk and/or bake all dynamics, so that the computer doesn't have to compute them again for every frame.
  • Keep your subsurf levels as low as you can, no more than 3... read this post.
  • Find the optimal tile size for your system
  • Keep the render samples as low as you can, set them to a noise level you can live with, remember for animation not all frames have to be as perfect as a still image.
  • Split the scene in different render layers that render efficiently, and composite them together into a final scene.

Avoid rendering directly to video formats: if your computer crashes you'd have to stat over! Always render as image sequences and encode to video afterwards.

Lastly (an option that been deprecated but might still be available on older versions of blender), for geometry that does not change through the scene: cache BVH.

enter image description here

  • $\begingroup$ Okay so I added a picture of what you said, is it a lot? $\endgroup$ Feb 6, 2016 at 3:13
  • 2
    $\begingroup$ For reference this is only available up to 2.76, it has now been removed for the next release. The improvements to the bvh creation made this option not useful. $\endgroup$
    – sambler
    Feb 6, 2016 at 6:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .