1
$\begingroup$

I tried to subsurf this model that I mirrored but when I use subsurf it splits the model into two objects.

Before Subsurf: enter image description here

After Subsurf: enter image description here

Any help would be appreciated.

$\endgroup$
5
$\begingroup$

A couple of things could be effecting your model.

  • Internal faces cause the subsurf modifier to "pull in". To fix this you need to delete the faces that will become internal faces after the mirror modifier duplicates your mesh.

Example of removing faces

  • The order that the modifiers are listed effects how they interact. Having the subsurf before the mirror can cause the edges in the centre of the mesh to pull away before the mirror duplicates the mesh. To fix this you need to have the subsurf under the mirror modifier. You can use the up and down arrows on the modifiers to re-order them.

  • If your subsurf modifier is after the mirror and the edges still shrink away from the centre of your object you need to enable merge in the mirror modifier. Enabling clipping in the mirror modifier can also help to get the centre vertices aligned so that they merge.

$\endgroup$
  • $\begingroup$ yes. this might be it. I have a face on the inside I will delete when I am done at work. Thanks. $\endgroup$ – ElerosVecchio Feb 5 '16 at 16:50
0
$\begingroup$

In the mirror modifier check the clipping box so that the intersection in the middle doesn't split if you haven't already applied the mirror modifier

$\endgroup$
  • 2
    $\begingroup$ Even when I have clipping turned on it doesn't connect when I apply the mirror modifier. Before I add subsurf I have to manually move the mirrored side to be aligned properly. $\endgroup$ – ElerosVecchio Feb 5 '16 at 14:43
0
$\begingroup$

From what your screen shot shows, these are my suggestions : Make sure that 'clipping' is turned on for the mirror modifier on the y axis, then add smooth shading to the model, and apply the mirror modifier. Then add a subsurf modifier. Apply the subsurf modifier, and all should look good.

$\endgroup$
  • 1
    $\begingroup$ the advice to set smooth shading + apply modifier aren't vital to showing the OP what the problem is here. $\endgroup$ – zeffii Feb 5 '16 at 8:30
  • $\begingroup$ Even when I have clipping turned on it doesn't connect when I apply the mirror modifier. Before I add subsurf I have to manually move the mirrored side to be aligned properly. $\endgroup$ – ElerosVecchio Feb 5 '16 at 14:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.