1
$\begingroup$

So I have a few animations I'm working on for a game I'm doing. The Idle animation is about 915 frames so it can be a nice long loop, and the walk animation is about 30 frames so as to be concise. However, when I am previewing and tweaking my Idle animation, and I want to switch to my walk animation, it sets the preview length as 915 frames. This of course leaves me with 885 frames of my character sitting in the air before the walk loop completes.

Example

As I'm exporting to an FBX for UE4, I'd really like to ensure each animation has a set length for proper looping in-game. Any ideas on what I missed to get this to happen? Thanks in advance!

$\endgroup$
0
$\begingroup$

I am sorry but I am having a really hard time understand what you are asking.

If I understand correctly you are exporting it and it is just doing nothing for 845 frames before starting the walk anim? If this what the problem is then I will let you know exactly how I expect my anim's to ue4 to prevent this.

Ok so first make shure each animation you have is in its own nla strip aka an action. So the idle would be in one action and the walk would be in its own action. Then you would set the keyframes equal to that action and export it with selected only check and uncheck the multiple nla strip thing in export settings (sry for not knowing the exact setting off the top of my head I am doing this from my phone). When you open it in ue4 it should be fixed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.